How do I enable Mouse Wheel Zooming ?

Q&A about the latest versions
Post Reply
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Thu Apr 16, 2015 9:34 am

Hi !

I'm a little confused as to how to enable zoom in and zoom out when viewing my panoramas in non full screen browser window.

The mouse wheel zoom functionality works great in Fullscreen mode, but not in standard browser mode.

I've played with the settings but can't seem to work out the answer. I'm using Mac with Firefox and Safari as manin browsers.

How do i enable mouse wheel zoom when not in full screen mode ?

http://www.rodedwards.co.uk/files/20634 ... way_1.html

Thanks ! :D
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
User avatar
360Texas
Moderator
Posts: 3530
Joined: Sat Sep 09, 2006 6:06 pm
Location: Fort Worth, Texas USA
Contact:

Thu Apr 16, 2015 4:59 pm

I see you are using Flash and zoom in/out is not enabled.

We are using Pano2vr Pro 4.5.3 so the dialog box might not be the same as yours.

FLASH output

/Advanced Tab\

[Control] dialog box
Sensitivity: use default setting 8
Movement: [x] Inertia
Mouse Wheel: Disable [deselect] and [x] invert control

all other Control items deselected

Delete your OUTPUT folder and rebuild your project which will create a new output folder
If your browser still is not using the new settings than suggest purging your browser cache to force a fresh copy of new files from your server. On a PC it is keyboard press and hold the SHIFT and enter keys 1 time. Or maybe a second time ... until the functions work.

If that does not work return to the project screen and click [Viewing Parameters] and view the Field of View (Zoom)

Ours is set for typical human eye vision of 50 and 110:
Min Fov in: (x) Degrees

Min: [50]
Max: [110]

Hope this helps
Dave
Pano2VR Forum Global Moderator
Image
Visit 360texas.com
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Thu Apr 16, 2015 5:43 pm

Thanks 360 Texas ... But i am basically using those settings apart from i've not got Control / Mouse / Invert Control ticked ( as i don't like Google Street View feel ).

These are my settings, but i'm getting no zoom effect on my Mac wired Mighty Mouse unles i'm in 'Fullscreen' mode.

Are you able to get zoom functionality on your computer ? Maybe it's my Mac Mouse ?

Here is the original link again : http://www.rodedwards.co.uk/files/20634 ... way_1.html

Screen grabs attached.

Thanks in advance ...
Attachments
Screen Shot 2015-04-16 at 16.41.21.jpg
Screen Shot 2015-04-16 at 16.41.21.jpg (33.75 KiB) Viewed 3591 times
Screen Shot 2015-04-16 at 16.32.20.jpg
Screen Shot 2015-04-16 at 16.32.20.jpg (124.23 KiB) Viewed 3591 times
Screen Shot 2015-04-16 at 16.32.50.jpg
Screen Shot 2015-04-16 at 16.32.50.jpg (119.74 KiB) Viewed 3591 times
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
User avatar
Hopki
Gnome
Posts: 11307
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Apr 16, 2015 6:29 pm

Hi,
Under the flash output and advanced settings tab deselect "Disable in browser" which is under Mouse wheel.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Thu Apr 16, 2015 9:38 pm

Hi Martin (Hopki) !

That's what i've done as you can see from the screen grab in my previous post, but the mouse wheel zooming still only works in fullscreen mode.

Any idea what the problem is ?

Here is the original link again - would you be so kind to test whether non full screen zooming works on your computers ?

http://www.rodedwards.co.uk/files/20634 ... way_1.html

Thanks
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Sat Apr 18, 2015 8:22 am

Incidentally, mouse wheel zoom works just fine in HTML5 mode - both in browser window and fullscreen ... just not Flash.

Can this be fixed ?
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Fri May 01, 2015 12:06 pm

Anyone else experiencing this problem with mouse wheel zooming in Flash ?

If it's a bug, be great to get it fixed as Flash is still really useful for 360's. :)
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
User avatar
JimWatters
Posts: 329
Joined: Thu Oct 07, 2010 6:16 pm
Location: Saint John, New Brunswick
Contact:

Fri May 01, 2015 3:21 pm

Your example works fine on my Windows PC with Firefox. So it may be related to your mouse and OS.

There is also no pinch to zoom with Flash on touch screens either.

I like a minimum number of controls in my UI. So I disable the zoom buttons for HTML5 but enable them for Flash only. This is done in the Skin Editor under the advanced settings for each button.

Personally I think Flash is only useful as a fallback. I use HTML5 as default.
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Fri May 01, 2015 3:26 pm

Thanks Jim, that's helpful to know.

Interesting that my mouse or OS is causing the mouse wheel zoom problem I'll look in to it more.

So you primarily use html5 - not Flash ? Do 99% of browsers now support HTML5 on all devices ?

As i understood it, HTML5 iDevice versions need to have a Splash screen to automatically activate any auto play sound on the 360. Not so with Flash - it just plays automatically. Is this still correct or have Apple changed the iOS again so sound can auto play without Splash screen ?
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
User avatar
JimWatters
Posts: 329
Joined: Thu Oct 07, 2010 6:16 pm
Location: Saint John, New Brunswick
Contact:

Mon May 04, 2015 2:55 pm

True Apple prevents auto play of audio.

Personally I think, not starting the audio by default, is a good idea. I prefer that when people share a link that contains auto start audio they add a, WARNING: Auto Start Audio, so neighbors are not disturbed. Like many now, I have headphones plugged in and set to one side, so I might not hear the audio, unless I was told to put my headphones on.

As a content creator and artist that spend time getting the perfect audio that goes with the tour I can understand why you want everyone to enjoy the whole experience as it was meant to be. Having a splash screen that indicates there is audio to be enjoyed on this tour is a great compromise.
NitromanX
Posts: 92
Joined: Thu Aug 07, 2008 9:09 pm
Location: UK
Contact:

Wed May 06, 2015 7:54 am

Thanks Jim ... I'm wondering about primarily switching over to HTML5 now it's much more widely supported :D
Professional photographer, videographer and 360 degree interactive panorama specialist.
http://www.rodedwards.com
Post Reply