Wordpress post not displaying on gallery page

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
iantresman
Posts: 46
Joined: Thu Aug 22, 2019 4:21 pm

Wordpress post not displaying on gallery page

Post by iantresman » Tue Nov 05, 2019 10:41 pm

I have a Virtual Tour Gallery page which is showing all my tours, except one. This particular "Little Planet" tour will display OK if
  1. I visit its post page,
  2. It appears OK on my Home Page.
  3. It appears in Chrome and MS Edge
It is not showing on the Galley page:
  1. In Firefox
  2. I've tried clearing the cache
When I display the page, the Firefox console is showing one error, but I don't know if it is significant: "TypeError: m is undefined".
This error does not appear if I do not display this particular tour post.

User avatar
Hopki
Gnome
Posts: 9595
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Wordpress post not displaying on gallery page

Post by Hopki » Thu Nov 07, 2019 5:47 pm

Hi,
Use your browser error console as your site is showing a few errors.
How are you embedding the panoramas?
Regards,
Hopki

iantresman
Posts: 46
Joined: Thu Aug 22, 2019 4:21 pm

Re: Wordpress post not displaying on gallery page

Post by iantresman » Thu Nov 07, 2019 6:03 pm

I'm using the [ggpkg id=815] embed, exactly the same on all other tours. This is the only one that doesn't seem to work, though the tour does work if I visit the post.

User avatar
Hopki
Gnome
Posts: 9595
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Wordpress post not displaying on gallery page

Post by Hopki » Thu Nov 07, 2019 6:11 pm

Yeah very odd.
As a test can you remake the panorama and then upload to your website and add that.
Does it show?
Regards,
Hopki

iantresman
Posts: 46
Joined: Thu Aug 22, 2019 4:21 pm

Re: Wordpress post not displaying on gallery page

Post by iantresman » Mon Nov 11, 2019 5:27 pm

As a quick workaround, I disabled one of my self-hosted GG tours, and the broken tour came back to life.

Should I be able to display more than one post, each with a Wordpress GG embedded tour? If I tried and embed two, one of them does not work. See my Two Tours Test page

User avatar
Hopki
Gnome
Posts: 9595
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Wordpress post not displaying on gallery page

Post by Hopki » Tue Nov 12, 2019 10:59 pm

Hi,
As a test, can you make sure all the tours use the same player?
Regards,
Hopki

iantresman
Posts: 46
Joined: Thu Aug 22, 2019 4:21 pm

Re: Wordpress post not displaying on gallery page

Post by iantresman » Wed Nov 13, 2019 10:53 am

Is there some documentation somewhere, on how to check whether the tours are using the same player, and how to fix it, if they are not?

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest