Image XMP metadata being assigned to wrong field upon import

Q&A about the latest versions
Post Reply
mbb
Posts: 202
Joined: Mon Oct 19, 2009 11:42 pm

Image XMP metadata being assigned to wrong field upon import

Post by mbb » Wed Dec 05, 2018 4:24 am

P2VR v6.0.1, Windows

See the below image-
Capture.JPG
Capture.JPG (12.06 KiB) Viewed 41 times
The above is what a cube face set generated by krpano droplet looks like when imported into P2VR. By default (all fields checked in P2VR->File-> Settings->ImageMetadata), P2VR is putting the file's XMP *description* into project's image UserData:Title. It should not be doing this.

Having dozens of previews all with the same "title" as shown above is problematic. Description != Title. If no XMP title is present, it should revert to the filename as default- and when doing so, it should remove trailing underscrores (which it presently does not).

mbb
Posts: 202
Joined: Mon Oct 19, 2009 11:42 pm

Re: Image XMP metadata being assigned to wrong field upon import

Post by mbb » Wed Dec 05, 2018 4:32 am

If I uncheck "Description" from the Settings->ImageMetaData, but leave all others checked, and import the same cubeface set, I get the following-
Capture2.JPG
Capture2.JPG (11.76 KiB) Viewed 37 times
Note how P2VR no longer tries to erroneously put the file's XMP:Description into UserData:Title, but that it also neglects to remove the trailing underscore that was part of the cubeface delineation (_f,_d,_b, etc).

Post Reply

Who is online

Users browsing this forum: 1uv3, Exabot [Bot] and 24 guests