Stop and Play video with timer? Rewind button?

Q&A about the latest versions
Post Reply
CKallas
Posts: 6
Joined: Tue Oct 23, 2018 10:45 pm

Stop and Play video with timer? Rewind button?

Post by CKallas » Wed Nov 07, 2018 7:28 pm

Some of you have probably read my earlier posts, but I have a series of animations/videos that transition seamlessly by the push of a button, either going back or forward with a series of actions that unhide and a play the necessary video. But when I load the start, it loads the videos on the screen in almost a random order and has them all visible but at different times. If I turn visibility off so they are not visible at the start, it loads fine, but then it has to load the video when you click the necessary button, so it screen goes black for like 4 frames and blinks instead of playing seamless to the next video.

So I currently have it like the first option where I load them all in the beginning and keep them loaded even after they are hidden and it transitions smoothly from video to video, but sometimes for some odd reason it will randomly make a video appear between the transition for like 3 frames, and then continue to play the video it was suppose to load. Like I said, it is completely random when it happens. It makes 0 sense because for every single video, I set actions to hide ALL of the other videos, but the one that needs to be visible and playing... Does anyone have any clue on why this is happening?!.. It doesn't happen if I have it "unload when hidden" but then I get them blank frames in between loading times for the next video, when I need it to be seamless.

SO... a solution I came up with that might fix both of these problems. Is there a way,I can have it all be one long video, but have it start and stop with buttons. I have all the animation segments 3 seconds long. So zoom in 1 is 3 seconds, part 1 is 3 seconds, part 1 to part 2 is 3 seconds. So my solution was, if you hit the play button or "next" button. Can you get it so it will automatically pause the video after 3 seconds until the user clicks the next or back button again? Same with something like going backwards?

Hard to explain all of this. I guess I would be willing to PM the project to a mod for help, but can't post public because it includes a client product.

Thanks!

CKallas
Posts: 6
Joined: Tue Oct 23, 2018 10:45 pm

Re: Stop and Play video with timer? Rewind button?

Post by CKallas » Thu Nov 08, 2018 6:46 pm

To dial in the the random video playing when I hit next for a frame thing. I found out it isn't playing a random video when I click next. it is actually playing the last frame of the current video for a frame, then starting the video from the beginning like normal. So not sure why this is happening. Working on a work around now.

User avatar
Hopki
Gnome
Posts: 8627
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Stop and Play video with timer? Rewind button?

Post by Hopki » Mon Nov 12, 2018 10:26 pm

HI,
If you're using the video element why not use one for each video and then use a preview frame.
I must admit without seeing what you're doing it is very had to understand what you seeing and what the problems are.
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: Baidu [Spider] and 28 guests