pinned video start/stop

Q&A about the latest versions
Post Reply
wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

pinned video start/stop

Post by wiso » Tue Jul 10, 2018 12:12 pm

hallo,
i am sorry, i have still another question to pinned videos:

in "klickmode" i have the options - nothing, start/stop, 100%, ...

but if i choose 100% i can not stop the video, i have to wait till it plays to the end.


is this right, or is there a possibility to stop the video before the end?

thx,
regards,
wiso

User avatar
Hopki
Gnome
Posts: 8634
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: pinned video start/stop

Post by Hopki » Fri Jul 13, 2018 1:06 pm

Hi wiso,
We had a lot of requests that popped out and popped out 100% also started the videos so we changed it to this way back at the start of V5.
So to check my understanding the video is pinned but not playing.
You want it to pop out and play, but then when closed stop.
I can not see a way to do this but then if this is the case why not have a pinned image then cover with a poly hotspot.
Then link it to a container that would open the video in the skin filling the screen.
You can then add a close button to hide and stop the video.
There are also skin actions that can effect pinned media, such as play/pause etc.
EDIT: This is a request in the bug track so will get looked at by the dev's at some point.
Regards,
Hopki

wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

Re: pinned video start/stop

Post by wiso » Wed Jul 25, 2018 10:23 am

hallo hopki,
thank you, seems a great idea with the polygon hotspot. but i have no idea how to link the polygon with the skin-video?!

i have the polygon:
Skizze (194).png
Skizze (194).png (261.84 KiB) Viewed 328 times
and i have the skin:
Skizze (195).png
Skizze (195).png (49.1 KiB) Viewed 328 times
i gave the video in a container (named v1) as you said.

but how to link it now? when i click the polygon, the video should be visible, e.g. play

thanks for help,
wiso

p.s.: its a little tricky to draw the polygon over the picture which you could see in this moment... but works.

User avatar
Hopki
Gnome
Posts: 8634
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: pinned video start/stop

Post by Hopki » Wed Jul 25, 2018 2:26 pm

Hi wiso,

In the attached project I have pinned an image to the pano, this is a frame from my video.
I then set the viewer to show a grid and zoomed in so I can place the pinned image in a know area using the grid in the viewer.
I then switched to Poly Hotspot Viewer mode and drew a poly around the area using the grid lines as a guide.

I then set the ID in the Poly Hotspot to: tb_video

.
In a new skin I selected the component, Video Popup Silhouette (File).
I created a container called Proxy_ID and copied the actions from the Hotspot Template to this. 
I then deleted the Hotspot Template and its image.

Under the containers properties you will see the Hotspot Proxy ID: tb_video.

I also modified the action in the container to:

Source: Mouse Click
Action: Set Value
Value: assets/short_tb.mp4
Target: popup_video_file

Finally under the HTML5 output and the Advanced tab I added the video: short_tb.mp4 to the assets.
I used Add files. This then create a folder called assets and places the video in there.

One last thing was in the skin I also gave the video element: popup_video_file, the action from the close button then removed the close button.

This allows you to click the pinned image to open the video but then still be able to use the scrubber and play pause button. Clicking the video or surrounding screen tint will close the video.
Regards,
Hopki
Attachments
project.zip
(3.15 MiB) Downloaded 16 times

wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

Re: pinned video start/stop

Post by wiso » Thu Jul 26, 2018 9:58 am

thank you hopki for the much work to make the example,
i copied your skin and only changed the video file to mine ( in the actions of the container "proxy_ID" ) and it worked.

but i am not realy understanding your line:
  • --- "I created a container called Proxy_ID and copied the actions from the Hotspot Template to this. 
I then deleted the Hotspot Template and its image.
"
what hotspot template (has the actions, and do you delete) ? i have only the polygon hotspot, and this one has no actions and i cant delete it...?

in the end i have more than one videos. therefore i like to understand how the polygon hotspot (tb_video) is connected with the container (proxy_ID). or isn´t it connected? is the connection on another place?

thanks,
wiso

User avatar
Hopki
Gnome
Posts: 8634
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: pinned video start/stop

Post by Hopki » Thu Jul 26, 2018 11:45 am

Hi wiso,
As I started my project from scratch I had to start a new skin.
So I used components toolbox and add the popup video (file) component.
This has a Point Hotspot which is not needed for your project.
I copied all the actions from the Point Hotspot Template then deleted it.
I then added a container to the skin which I gave it the ID: Proxy_ID then copied the actions from the now deleted Hotspot Template into the container.
Most of the above you don't have to worry about, but I needed to do this to make the skin.

So now you just add your pinned image and then add a Poly Hotspot over it.
Give the Poly Hotspot an ID such as: tb_video, only because this is the video it will open.

Back in the container and under its properties you enter under the Hotspot Proxy-ID text field: tb_video which is the Poly Hotspots ID.
What this does is makes a link between the Poly Hotspot and the container.
So when you click the Poly Hotspot its like clicking the container.

If you wanted this to work with different Ploy Hotspots and videos you would create a container for each video.
Then each Poly Hotspot which will have its own unique ID which will then be linked to its corresponding container which will open the correct video.
Regards,
Hopki

wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

Re: pinned video start/stop

Post by wiso » Thu Jul 26, 2018 2:11 pm

I think I got it!

Thank you very much!

wiso

wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

Re: pinned video start/stop

Post by wiso » Wed Aug 08, 2018 7:01 pm

thank you hopki,
its great, works fine and i can use it good!

but seems only on pc... iphone /ipad dont work. video woudnt start. android i havent´tested.

i think it is not so necessary for my work, but maybe you know a solution also for mobile devices.

greetings
and thank you,
wiso

wiso
Posts: 151
Joined: Wed Oct 26, 2016 6:52 pm

Re: pinned video start/stop

Post by wiso » Mon Aug 20, 2018 12:27 pm

and, sorry, the second thing is that the videos stutter in firefox.
in chrome and IE it works withaout problems.

it seems that it has to do with the cache, but it makes no different to play all videos one time full length, afterwords it is not better.

do you have a solution ?

best regards,
wiso

p.s.: i will send you the link via pm. maybe you have time to make a look at it.

Post Reply

Who is online

Users browsing this forum: No registered users and 23 guests