Ggpkg not showing in Joomla, what I do wrong?

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
Frankster69
Posts: 54
Joined: Mon Sep 18, 2017 12:54 pm

Ggpkg not showing in Joomla, what I do wrong?

Post by Frankster69 » Wed Oct 11, 2017 5:03 pm

Hi guys,

Sorry for yet another perhaps stupid question :)

I've tried uploading my tour using the ggpkg plugin in Joomla. After inserting the {ggpkg fil="ID"} code in an article, it does not show anything, it shows only the {ggpkg} line. If I try to load a module via {loadmodule} that works, so Joomla is executing code in curly brackets. I must be doing something wrong...

This is what I did:
- I created HTML5 output, with 'Create files for external embedding' checked in the normal.ggt template.
- I zipped the files in the output foler, minus the image/tiles folders.
- I renamed the zip to huissevenaer.ggpkg and uploaded that via the Media manager in Joomla
- The plugin did it's work and in my FTP I can see a folder ggpkg in the Media folder, and within it a folder 'huissevenaer.ggpkg' containing the json/index/xml/js files. So the decompression worked.
- I then uploaded the images/tiles folders to that directory (230MB)
- Created a new article with this line: {ggpkg file="huissevenaer" start_preview="true" width="320" height="240"}

As far as I can tell that would be all I need to do right? Yet when I open that article on the front-end, I see this:
ggpkg-not-showing.jpg
ggpkg-not-showing.jpg (22.3 KiB) Viewed 1243 times
The second line of code in that screenshot is from a HTML module I made to test if it works that way, that is also loaded in the article via {loadmodule ggpkg}, which proves Joomla does execute such code in an article.

I've tried loading the page with a default Joomla template, but same thing. So it's probably not the template.

Somehow Joomla is unable to make the ggpkg plugin work in an article, but the plugin does work in uploading and unpacking the ggpkg file.

FWIW: a regular FTP ulpoaded tour works, so the tour itself is not the problem.

What can I do to make it work?

regards, Frank

PS: Sorry, this is a re-post post from the main P2V forum, I hadn't realised there's a forum for the CMS plugins. I've deleted my post there.

Frankster69
Posts: 54
Joined: Mon Sep 18, 2017 12:54 pm

Re: Ggpkg not showing in Joomla, what I do wrong?

Post by Frankster69 » Sat Oct 14, 2017 8:10 pm

Nobody? I really would like to have it working... Any help appreciated,

regards, Frank

User avatar
Hopki
Gnome
Posts: 9082
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Ggpkg not showing in Joomla, what I do wrong?

Post by Hopki » Sat Oct 14, 2017 8:26 pm

Hi Frank,
Have you ever had this working or is this is a new fault?
Can you try using the test ggpkg file and just upload using the media manager. As the test files are small there is no need to use FTP and upload the images and tiles separately.
Also do you use K2 articles as this is know the brake the plugin.
Regards,
Hopki

Frankster69
Posts: 54
Joined: Mon Sep 18, 2017 12:54 pm

Re: Ggpkg not showing in Joomla, what I do wrong?

Post by Frankster69 » Sat Oct 14, 2017 11:55 pm

Hi Hopki,

Thanks for the reply :) I hadn't, but I've just tried both testfiles. No luck I'm afraid. They both upload well, but only Reindeer produces a folder in Media/ggpkg if I check with ftp. Light_painting does not? Light_painting shows up in the media manager, but not in de the ftp filestructure (Filezilla).
mediamanager.jpg
mediamanager.jpg (15.77 KiB) Viewed 1211 times
ftp-folders.jpg
ftp-folders.jpg (55.1 KiB) Viewed 1211 times
Neither of them show up in an article. Same result: the bracket code shows plain, with the correct format and the name of the ggpkg, but no panorama.

If it's of use, you can examine the page's source? The site is under construction and I have used an arbitrary menu-item to test this with, the url is:
http://www.free-frank.net/plan-pricing

No I'm not using K2, but I am using a Joomla that is wrapped around the Helix 3 framework. So now I'm guessing this is just not going to work for me now?

Anything else I can try?

From their website (Joomshaper) :
Helix3 isn’t just a template or a plugin, it’s a complete Joomla 3+ template framework.
https://www.joomshaper.com/joomla-templates/helix3

regards, Frank

Oh, and no, this is my first attempt, I haven't got Pano2VR that long yet. So never had it working and never tried.

User avatar
Hopki
Gnome
Posts: 9082
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Ggpkg not showing in Joomla, what I do wrong?

Post by Hopki » Thu Oct 26, 2017 1:36 pm

Hi Frank,
Maybe send a ggpkg to the developers of the Helix 3 framework.
The plugin works ok with Joomla and my test site is working fine so I suspect it has something to do with the framework.
Here is a link to me test site: Hopki
Regards,
Hopki

Frankster69
Posts: 54
Joined: Mon Sep 18, 2017 12:54 pm

Re: Ggpkg not showing in Joomla, what I do wrong?

Post by Frankster69 » Sat Oct 28, 2017 6:33 pm

Hi Hopki,

I suspect you are right. Not sure if they will listen, because I use their free framework, no paid extensions for it. But given time I'll give it a try. For now the iframe is easier and satisfactory.

thanks!

regards, Frank

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest