Auto start?

Q&A about the latest versions
Post Reply
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Mon May 04, 2009 11:23 pm

I've got a 67 frame object movie (.swf) and the client wants is set to auto rotate. But the problem is that it starts to rotate as soon as the file starts to load. So the loading bar is blocking part of the image. By the time it fully loaded just a few seconds, the auto rotate has taken the viewer 7 or 8 frames into the movie. The opening effect is missed as well as the images.
Is there a way to have the auto rotate start after the file is fully loaded?

JeffN
PhotoSpherix
Posts: 294
Joined: Wed Oct 22, 2008 9:45 pm
Location: Beech Grove
Contact:

Tue May 05, 2009 2:26 pm

Jeff, I did a test.

http://www.photospherix.com/flash_client.asp?id=ever

Here is how I did it.

Made the object, added 20 images then went to skin editor. I had a test skin that had the logo in the loading screen and had a handy place to look for the loaded command. I opened the skin editor. Found the Loading Image and looked for the actions for LOADED. Then I added a new LOADED action that was "Toggle Auto Rotate". I then saved the skin. I then changed the speed of "Auto Play" but did not turn on auto play. There you have it. It waits till loaded to auto play.
PhotoSpherix
Starting a revolution in Photography
360 Product Photography
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Tue May 05, 2009 5:48 pm

PhotoSpherix...

Brilliant!!! :D

That is exactly what I'm looking for. Now I need to learn how to do that myself.
Let me ask a few questions about your reply.
My Object2VR software has two skins in the Flash output window.(default and controller_object_popup.ggsk)
I have opened the skin editor and although I haven't used it, I think I get the basic idea, hopefully I can figure things out.
Some of the terminology it foreign to me.

So for my questions:

1)
Found the Loading Image and looked for the actions for LOADED.
What are you referring to as the "Loading Image" and where will I find the "actions" for the "Loaded" ?

2)
Then I added a new LOADED action that was "Toggle Auto Rotate".
How do I add / create this new loaded action and where do I set it to "Toggle Auto Rotate" ?
I then changed the speed of "Auto Play" but did not turn on auto play.
This part I understand, these controls are in the Flash Output window.

3) In the skin editor, on the right side, under "Tree" it shows items like:
loading image (-112,-32)
loading text (12,40)
and symbols, arrows, + -, various buttons
The numbers in the ( ) are the placement xy coordinates in the skin window,
but where do I get these and other buttons / items?

4) Are there other skins out there to pick from?

So if you can walk me thru this further (and others that may be studying)
I"ll be a good student (and grateful).

JeffN
PhotoSpherix
Posts: 294
Joined: Wed Oct 22, 2008 9:45 pm
Location: Beech Grove
Contact:

Tue May 05, 2009 7:07 pm

I will try my best, I hope that a couple images will help out.

OK so we have an object that already has a few images in it. we have added a flash output to the project. This should open the flash output settings window.

Image

Now we change the skin/controller to the one of our choice. I will be using controller_new

I now want to edit that skin. I click edit and I get the skin editor window.

Image


If I look on the right side of the skin editor I see a tree of the parts of the skin. I double click on the "loading image" in the tree on the right. It then opens an additional dialog box

Image

Within this dialog box I add an action
I use the source pull down to choose loaded and the action pull down to choose toggle auto

Image

As far as other skins. You can now save this skin as another name and you have another skin. I have a lot of skins, but they are not available for distribution. I want to be able to load a swf in the skin THOMAS!!!!!! PLEASE
PhotoSpherix
Starting a revolution in Photography
360 Product Photography
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Tue May 05, 2009 9:34 pm

:D :D :D :D
Ever though about being a teacher?
Your instructions were easy to follow. The screen shots made it almost a no-brainer.
Hopefully this will be useful to others researching this forum.
I have another question but I'll put it on another post so it's out there for others.

Thanks again for a great job.
JeffN
JeffN
Posts: 51
Joined: Wed Mar 04, 2009 3:40 pm

Mon Jul 13, 2009 5:26 pm

PhotoSpherix,
I followed your excellent instructions and and everything worked as you said except one thing:
With the Auto Rotate set to OFF, I found the speed that I set (same speed as when set to auto rotate) was now much faster than before. It's not adjustable anymore, different values in the box don't effect any change in speed. It's just a fast spin. Also I can't pick the Ping-Pong in the rotate mode because it's set to OFF when using the auto rotate action.
Are you able to use a very slow speed? when using the rotate after load action. Are you experiencing any of these issues?
Thanks in advance for a reply,

JeffN
Post Reply