WordPress plugin suddently ignores "width" param

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
Howard
Posts: 209
Joined: Wed Jun 03, 2009 5:58 am

While yesterday this page was displaying just fine:
https://allaroundnevada.com/donner-summit/

The VR just under the first text block is set to display at width=95%
And until today, it displayed as expected.
But now, on all browsers, it displays as a square.
I didn't change anything, but this occurs on several websites where I've deployed the same plugin and shortcode.

The GGPG shortcode is:

Code: Select all

<center>[ggpkg url='https://allaroundnevada.com/wp-content/vr/nearly/donner/combined/index.html' start_preview='false' gyro='true' width='95%' height='600']</center>
For a comparison, I've duplicated the pano at the bottom of this page, using an iFrame set to 95% width.

Is there an issue with the plugin perhaps...or is there something else I've overlooked?

Thanks!

Howard
User avatar
Hopki
Gnome
Posts: 12972
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Hi Howard,
Thanks for the heads up we will look into this.
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Pieter
Posts: 3
Joined: Wed Nov 01, 2023 11:23 pm
Location: Innlandet, Norway
Contact:

Hi,

Yesterday I encountered the same issue. It looks like the width in percentages is not working in Wordpress since the plugin update.
In the Wordpress settings for the default player size, I can't save width in %. It will save, but when I come back later the value has not been stored.

I use the Avada template and the width of the player is supposed to scale in width with the column:
https://zeebeen.no/

In my old website it does still work:
https://www.zeebeen.nl/virtual-tour/

Hope that helps width finding the issue

Thanks,

Pieter
User avatar
thomas
Chief Gnome
Posts: 2609
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

This issue should now be fixed with version 2.2.7 of the plugin.
MfG, Thomas
User avatar
Pieter
Posts: 3
Joined: Wed Nov 01, 2023 11:23 pm
Location: Innlandet, Norway
Contact:

Thanks. Yes, its working with the attribute like this for every player on the site: [ggpkg id=495 width='100%']
So the site is working again.

I didn't get it to work for the site as a whole, by setting the Default Player Size to width: 100%. The value is not stored and resets to another value.

Saving:
ggnome-1.JPG
ggnome-1.JPG (46.79 KiB) Viewed 28065 times
Return to the settings afterwards:
ggnome-2.JPG
ggnome-2.JPG (43.94 KiB) Viewed 28065 times
Howard
Posts: 209
Joined: Wed Jun 03, 2009 5:58 am

Thanks for the rapid response and the new version of the plugin.
The fix worked, but only after I disabled, and then re-enabled the plugin.

Whew!
User avatar
thomas
Chief Gnome
Posts: 2609
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Pieter wrote: Thu Nov 02, 2023 1:34 pm I didn't get it to work for the site as a whole by setting the Default Player Size to width: 100%. The value is not stored and resets to another value.
We have now released 2.2.8, which addresses this issue. I hope we now caught all issues. 🤞🏻
MfG, Thomas
User avatar
Pieter
Posts: 3
Joined: Wed Nov 01, 2023 11:23 pm
Location: Innlandet, Norway
Contact:

Yes, all back to normal.

Thank you, Thomas!
Post Reply