"Warning: Illegal string offset" in Wordpress

Everything concerning the Wordpress/Joomla/Drupal plugins
Post Reply
User avatar
Jijel
Posts: 10
Joined: Sun Dec 09, 2007 12:17 pm
Contact:

Fri Apr 27, 2018 7:49 pm

Hi all,

after uploading a ggpkg file to Wordpress ( 4.9.5 with ggpkg plugin 1.4.5) I'm getting lots of "Warning: Illegal string offset" warnings referring to ggpkg-import.php in the media library entries for ggpkgs. As far as I can tell the warnings have something to do with how metadata is imported from the pkges. The files still work but it is pretty annoying because the messages take up a lot of space. This also happens with the ggpkg test files. The only thing that appears to be broken (if due to this error I'm nopt 100% sure) is setting a master pano via the settings.

Is there a way to get rid of the warnings?

Kind regards,

Chris
User avatar
Hopki
Gnome
Posts: 10757
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Apr 30, 2018 3:23 pm

Hi Chris,
I have raised a bug report for this.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Jijel
Posts: 10
Joined: Sun Dec 09, 2007 12:17 pm
Contact:

Mon Apr 30, 2018 6:14 pm

Thanks. I'll add a screenshot, maybe it helps.

Screenshot
Screenshot
2018-04-30.png (204.22 KiB) Viewed 8676 times
Kind regards,

Christian
User avatar
Hopki
Gnome
Posts: 10757
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sun May 13, 2018 9:12 pm

HI Christian,
The plugin has been updated but is still 1.4.5. Please remove the one from your Wordpress site and install the new one.
Let me know how you get on.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Jijel
Posts: 10
Joined: Sun Dec 09, 2007 12:17 pm
Contact:

Mon May 14, 2018 5:44 pm

Hi Hopki,

thanks for looking into the issue. Unfortunately the Problem persists.

I deleted the old plugin, installed the new one (from https://ggnome.com/ggpkg). Uploaded a pano: "Warning: Illegal string offset 'file' in /homepages/12/d65739805/htdocs/4wolf/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 586".

Kind regards,

Christian
User avatar
Hopki
Gnome
Posts: 10757
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon May 14, 2018 11:35 pm

Hi,
Iv tested this with a standard build of Wordpress and the plugin and GGPKG is working ok.
When did the start?
Did you do an update with other plugins in your Wordpress site?
Not sure how far we got with this but did you send me your ggpkg, if not can you.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Jijel
Posts: 10
Joined: Sun Dec 09, 2007 12:17 pm
Contact:

Tue May 15, 2018 1:14 pm

I just found the source of the problem: Themes. Apparently some themes do something the ggpkg-plugin doesn't like. "Graphene" for example produces the error for me.

Kind regards,

Christian
User avatar
Hopki
Gnome
Posts: 10757
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue May 15, 2018 3:32 pm

Hi Christian,
Thanks for finding this, I will add this to the know issues list.
Cheers,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
KAB_NL
Posts: 10
Joined: Tue Apr 21, 2009 12:18 pm
Location: St. John's, Newfoundland and Labrador, Canada
Contact:

Wed May 01, 2019 9:56 pm

Has there been any progress on this issue?
I have had no problems until I upgraded my Server's PHP from 5.4 to 7.1
Now I am getting multiple media library warnings on import; examples follow:

Warning: Illegal string offset 'file' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 586
Warning: Illegal string offset 'thumb' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 587
Warning: Illegal string offset 'mime-type' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 588
Warning: Illegal string offset 'width' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 591
Warning: Illegal string offset 'height' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 592
Warning: Illegal string offset 'sizes' in /home3/qlinear/public_html/360panos/wp-content/plugins/ggpkg-import/ggpkg-import.php on line 602

I have not tried to revert to the previous PHP version since WordPress is telling me that I need to be running 7.+ for security reasons. I have several sites on the same server that are benefitting from the PHP upgrade with no issues. Only one site is using the Ggpkg Plugin. I was just getting geared up to update this site and now this :( . Any suggestions??

Thanks
Newfoundland Panoramas
Q-Linear Ltd (Imaging and Panoramas)
https://nlpanos.qlinearimaging.com/
http://360panos.qlinearimaging.com/
KAB_NL
Posts: 10
Joined: Tue Apr 21, 2009 12:18 pm
Location: St. John's, Newfoundland and Labrador, Canada
Contact:

Sat May 18, 2019 4:07 pm

So I went back to PHP 5.6 and the problem stopped. When I get some time I'll test the effect of my plugins and theme.
Newfoundland Panoramas
Q-Linear Ltd (Imaging and Panoramas)
https://nlpanos.qlinearimaging.com/
http://360panos.qlinearimaging.com/
User avatar
thomas
Chief Gnome
Posts: 2563
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Sat May 18, 2019 5:55 pm

Please install the latest version 1.4.6 of the Wordpress plugin that fixes this issue.
MfG, Thomas
User avatar
edgar_ali
Posts: 158
Joined: Wed May 03, 2017 12:00 pm
Location: Autralia
Contact:

Tue May 21, 2019 2:13 am

Thomas:

Thanks for the update..

just a quick question: To update the plugin I had download the version 1.4.6, then deactivate and delete the previous version, then installed and activate the version 1.4.6.

Is there another way of doing this like all the other plugins in Wordpress, that they update without the need of deactivating and deleting previous versions?...

Or I am doing something that is not right?
User avatar
thomas
Chief Gnome
Posts: 2563
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Tue May 21, 2019 12:06 pm

you can just replace the files on the server.
MfG, Thomas
Post Reply