iOS 7 crashes my Pano2VR HTML5 content

Q&A about the latest versions
Post Reply
Howard
Posts: 172
Joined: Wed Jun 03, 2009 5:58 am

Thu Sep 26, 2013 5:08 am

OMG... everything worked just fine for me before I upgraded to iOS7 on my iPad 3 yesterday. But now both of my p2VR sites crash Safari, either when first launching a pano or when going to a second hotspot link.

This happens in both my hard-coded WordPress site:
http://voicesfromthedawn.com

and in my shortcode (PanoPress) enabled site:
http://allaroundnevada.com

Any suggestions will be greatly appreciated.

Howard
Kay-Uwe Rosseburg
Posts: 31
Joined: Tue Jan 27, 2009 3:12 pm
Contact:

Thu Sep 26, 2013 4:02 pm

Yes, mine too! Safari crashes and Chrome-Browser, both on iPad 4 with fresh upgrade iOS 7.
http://www.panorama-photography.com

Any ideas?

Greetings
Kay-Uwe
RobM
Posts: 249
Joined: Sat Apr 16, 2011 12:51 pm

Thu Sep 26, 2013 4:19 pm

yup. iOS7 is the proverbial POS.

25 node tour. Runs fine on my iPad Mini iOS6something

Crashes the heck out of my iPad4 with iOS7.

Top tip. DO NOT upgrade. Something someone in Appleland is messing things up.
Howard
Posts: 172
Joined: Wed Jun 03, 2009 5:58 am

Thu Sep 26, 2013 9:10 pm

Well, it's kinda nice to know that I'm not alone.

Are panos working for anyone in iOS7? If so, what are they doing differently?

All help is appreciated with this critical problem (Hopki?)

Thanks,
360vr_nl
Posts: 51
Joined: Wed Apr 27, 2011 5:26 pm
Location: The Netherlands
Contact:

Fri Sep 27, 2013 1:18 pm

Webkit in iOS 7 seems a not finished and rushed job. See also: http://www.sencha.com/blog/the-html5-sc ... y-in-ios7/
I think they were anxious to get iOS 7 out because of the launch of the new iPhones, despite it being not ready yet :(

However, it seems to work OK on my iPad 2. I can access your pano's without problems and without crashes.
Maybe it is because I am using an iPad 2?

Did you empty the Safari caches on your iPad?

I don't think Thomas (nor Hopki) can do anything about it. The wait is for the 7.1 update, I am afraid...
Kay-Uwe Rosseburg
Posts: 31
Joined: Tue Jan 27, 2009 3:12 pm
Contact:

Fri Oct 04, 2013 3:23 pm

O.k., I solved the problem for me, I had to add the setting in the mobile tab:
iPad (3) device screen 24Nov2012 2048 x 1536 pixels 264 ppi. -> 2048 Cubeface/tile 960 On HTML tab click full screen [x] option
I did not use the max screen-size 1025, as it was adviced in the sticky thread, but I put 2048 in the max screen-size tab.
So im my case it seemed to be a problem of the new ipad (I just bought one new, so I did not notice it before), rather than ios 7.

Maybe this helps someone.

Kay-Uwe
Howard
Posts: 172
Joined: Wed Jun 03, 2009 5:58 am

Tue Oct 08, 2013 5:35 am

Thanks, Kay. This does help. I was previously using mobile settings provided me by a GG insider, and those settings worked until iOS7. Now I guess I have to go back and remake the xml file for each page in my site.

<sigh>

Something I wish that I was creating a book instead. Not many changes since moveable type.

Howard
Post Reply