Question on "Adding a YouTube Video"

Q&A about the latest versions
Post Reply
User avatar
malaga360VR
Posts: 43
Joined: Tue Sep 18, 2012 10:36 pm
Location: Spain / Málaga
Contact:

Mon Dec 10, 2012 10:09 pm

Hello want to do a test with this tutorial but something is wrong and I would like to know what I am missing.

I am following this :
Adding a YouTube Video
For Pano2VR V3
Step 1
Open YouTube and select the video you want to embed. Make sure that you can embed the video, not all can.
Right button click on the video to show the context menu, click “Copy embed code”, please note this will not be in the context menu if the owner of the video does not want you to embed it.
Open a document and paste this code to see it:
<object style="height: 390px; width: 640px"><param name="movie" value="http://www.youtube.com/v/BfIAKj3Gl1E?version=3"><param name="allowFullScreen" value="true"><param name="allowScriptAccess" value="always"><embed src="http://www.youtube.com/v/BfIAKj3Gl1E?version=3" type="application/x-shockwave-flash" allowfullscreen="true" allowScriptAccess="always" width="640" height="390"></object><br />
The bold areas are what you will need to embed the video, file location and window size, http://www.youtube.com/v/BfIAKj3Gl1E?version=3 and 390, 640.
I get different syntax but link works ok ,I have searched html5 compatible and I get this one :

Code: Select all

<iframe width="640" height="390" src="http://www.youtube.com/embed/P4wI_o8gyxA" frameborder="0" allowfullscreen></iframe>
Step 2
Open the skin editor and click on the Add external Image/SWF button.
Add an external box in the skin and open it.
Set the window size of the external box to match the size of the embedded video and copy and paste in the code in to the External Url text field. Anchor centre and out put the file.
Loading: this check box unloads the video when hidden which means another video will be able to be played.
I'm doing this :

Image

And :

Image

Here I really don't know to set on link the proper window size ( 640 x 340 ) , may be is that the error, I'm not sure, if a click right mouse and choose open on another page , link works and video is there .

But on Panorama I only get :

Image

Any suggestion to solve this ?


Thanks for help
kris
Posts: 105
Joined: Wed Feb 15, 2012 9:37 am

Tue Dec 11, 2012 9:49 am

Hi You need to make two seperate skins for Swf & HTML format then use step 1 for Swf format & step 2 for HTML format. output the panos in SWF & HTML format with flash fall back enabled or disabled.
User avatar
malaga360VR
Posts: 43
Joined: Tue Sep 18, 2012 10:36 pm
Location: Spain / Málaga
Contact:

Tue Dec 11, 2012 12:02 pm

thanks for help

But I don't understand , Step one describes how to get the link , and step 2 describes how to insert it in the skin .

Here you are project
Archivo comprimido.zip
doomy.p2r,doomy.jpg,simplexvidlink.ggsk and output folder with generated files
(643.23 KiB) Downloaded 95 times
for anyone if can make it run properly.
kris
Posts: 105
Joined: Wed Feb 15, 2012 9:37 am

Tue Dec 11, 2012 6:59 pm

Hi it seems that youtube is not supporting embeding into flashsites anymore, the embed code we are getting is an HTML version not the flash, even the pano2vr example is not working http://www.youtube.com/watch?feature=pl ... fIAKj3Gl1E if you copy embed HTML code. but after a lot of search & attempt i found this" http://support.google.com/youtube/bin/a ... wer=171780 " how to obtain the old code. read '"Use old embed code" and successfully played ur video of portrait retouching. i have attached the skins & screen shot. now it will work fine :D. thanks to you that i was not aware of this.

regards

kris
Attachments
imasoft.jpg
imasoft.jpg (60.65 KiB) Viewed 2217 times
simplexvidlink_SWF.ggsk
use for SWF output
(482 Bytes) Downloaded 86 times
simplexvidlink_HTML.ggsk
use for HTML output
(632 Bytes) Downloaded 74 times
User avatar
malaga360VR
Posts: 43
Joined: Tue Sep 18, 2012 10:36 pm
Location: Spain / Málaga
Contact:

Thu Dec 13, 2012 12:03 am

I will study it carefully , now is late for me.

It is nice to know that in this forum are good people helping.

Thanks a lot !!
User avatar
Hopki
Gnome
Posts: 10623
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Dec 13, 2012 7:14 pm

Hi,
The add YouTube video Tip did use the "old embed code" but I have noticed that quite a few videos do not give you this option.
The Tip has a way around this, still needs a bit of tiding up but can be found Here.
Now also covers the HTML5 output.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
malaga360VR
Posts: 43
Joined: Tue Sep 18, 2012 10:36 pm
Location: Spain / Málaga
Contact:

Thu Dec 13, 2012 7:43 pm

I prefer HTML5 if its possible, that is a very good info !!!!!!

Do you know if it is possible to embed video if I have my own ISP provider ? , I could host it on it like I do with my panoramas, web , mail , etc ....
Post Reply