[P2VR 3 b5] Area Hotspot: Maximum images size exceeded!

Q&A about the latest versions
Post Reply
Judy-A
Posts: 242
Joined: Sun Jan 10, 2010 5:26 am
Location: Edmonton, Canada
Contact:

Sun Mar 13, 2011 11:25 pm

I have an equirectangular image that is 10,696 pixels wide. When I click on

Hotspots>Modify>Area Hotspots>Enabled

I get a warning message “Maximum images size exceeded!” I am prevented from creating area hotspots.

Is this normal?

What is the maximum pano size for which Area Hotspots can be enabled?

Judy
--
Pano2VR 30 beta5 64bit
Mac Pro Quad Core Intel Xeon
Mac OS 10.6.6
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Mon Mar 14, 2011 7:39 am

Hi Judy,

Area hotspots always cause issues with memory. But you can help the issue by adjusting your settings.
(or whatever it is in the MAC version)
hotspot_settings.png
hotspot_settings.png (24.99 KiB) Viewed 2743 times
Hope this helps on this occasion.

Regards, Smooth 8)
Image
User avatar
Hopki
Gnome
Posts: 10759
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Mar 14, 2011 12:24 pm

Hi
If I may add to this, the warning kicks in at 40,000,000 pixels which you can choose to engorge if your computer has plenty of Ram, the problem is that Pano2VR has to make several copies of the input image, this caused the memory of the average computer to fill up which caused the problems.

Edit cube faces as horizontal cross, this works when you use cubes as the input image, un tick this box then you will be able to add area hotspots to the individual cubes rather than to the one large image.

Regards
Hopki
Attachments
Screen shot.png
Screen shot.png (184.93 KiB) Viewed 2735 times
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Judy-A
Posts: 242
Joined: Sun Jan 10, 2010 5:26 am
Location: Edmonton, Canada
Contact:

Mon Mar 14, 2011 11:24 pm

Hopki wrote:If I may add to this, the warning kicks in at 40,000,000 pixels which you can choose to engorge if your computer has plenty of Ram,
All of my panos are 16-bit images that are larger than 40,000,000 pixels.

The “Ignore size limit” preference was already unchecked.

This Mac has 6 GB of RAM, which has been plenty for stitching panoramas in PTGui Pro 9 and Autopano Giga, and for editing of multilayer 16-bit PSB panoramas in Photoshop CS4. I’ve never had a size warning from any of those programs.

Surely P2VR should be able to handle smaller files. Is it ignoring the unchecked “Ignore size limit” preference?

As a test I logged out of my user account, logged back in and opened only P2VR. I still get the warning message.

Judy
Pano2VR 30 beta5 64bit
Mac Pro Quad Core Intel Xeon, 6 GB RAM
Mac OS 10.6.6
User avatar
Hopki
Gnome
Posts: 10759
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Mar 14, 2011 11:50 pm

Hi Judy
Some confusion I think, to ignore the limit, it has to be checked.
You only Un check Edit cube faces if you start to get memory errors so you can add area hotspots to cubes rather than a complete image.
As said, this was put in place for computers with less ram.
Please let me know if you have further problems.
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Judy-A
Posts: 242
Joined: Sun Jan 10, 2010 5:26 am
Location: Edmonton, Canada
Contact:

Tue Mar 15, 2011 12:04 am

Hopki wrote:Hi Judy
Some confusion I think, to ignore the limit, it has to be checked.
Doh! Of course! I'll give it another try. :oops:

Judy
kalain
Posts: 11
Joined: Wed Nov 29, 2006 1:42 pm

Sun Mar 20, 2011 6:47 pm

Hopki wrote:Hi
If I may add to this, the warning kicks in at 40,000,000 pixels
It's bit higher than this because (At least with 2.3.4) 9000*4500 is ok, which is 40,500,000 px.

Anyway, even if you check "Ignore size limit",you can draw hotspots on 10,000*5,000 px but png file is not created! :shock:
User avatar
Hopki
Gnome
Posts: 10759
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sun Mar 20, 2011 8:52 pm

Hi
V2.3.4 dos not have the notification. :wink:
As I have already said in this thread, this notification can be turned off and was for computers with limited memory.
We were getting a lot of people saying that they were getting errors due to memory problems when setting area hotspots so we put this in. If you computer has lots of memory then you will be able to work with larger images.
Regards
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply