fullscreen will nicht

Fragen und Antworten zu Pano2VR in deutscher Sprache
Post Reply
blacky10
Posts: 4
Joined: Sat Sep 25, 2010 4:43 pm

Sat Sep 25, 2010 4:54 pm

hallo @all,

ich habe da ein kleines problem ich komme mit der software eigenlich 1a zurecht nur eins will mir nicht gelingen.
grundsätzlich lasse ich die pans alle in flash erstellen.
wenn ich eines mit html erstelle nd über meine html starte bekomme ich ein fastvollbild , mit einem streifen und dem close link. drücke ich auf den fullscreen button dann ist mein ganzer bildschirm ausgefüllt, so wie es sein sollte.
binde ich die flashdatei auf eine webseite ein dann geht er nicht auf vollbild bei drücken, ich habe das aber schon auf irgendeiner webseite gesehen das es geht, weis jemand rat oder eine link.

gruss blacky
blacky10
Posts: 4
Joined: Sat Sep 25, 2010 4:43 pm

Sun Sep 26, 2010 11:26 am

hallo @ all,

habe eine lösung gefunden. ich erstelle nun den player in flash mit html normal.ggt und binde ihn über enien iframe in die seite ein.
dann funktioniert auch der fullscreen beim drücken des fullscreenbutton .
vielleicht hilfst das ja jemand mal weiter

gruss blacky
User avatar
Hopki
Gnome
Posts: 11124
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Oct 06, 2010 1:31 pm

Hallo Gruss

Anstatt Putting iframe etc, man musste nur die Vollbild-Parameter auf der HTML-Seite hinzufügen.

<param name="allowFullScreen" value="true" />

Regards
Martin



Hi Gruss

Rather than putting iframe etc, you just needed to add the full screen parameter to your html page.

<param name=”allowFullScreen” value=”true” />

Regards
Martin
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Nikolai
Posts: 35
Joined: Sat Oct 02, 2010 3:09 pm

Wed Oct 13, 2010 5:36 pm

Um den weißen Rand weg zu bekommen musst du in der html Datei die Fenstergröße auf 100% setzen (müsste bei dir au 95% stehen.)

Zusätzlich löscht du folgende Zeilen:

<p align="center">
<a href="javascript:close();">close</a>
</p>

lg
nikolai
User avatar
Hopki
Gnome
Posts: 11124
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Oct 14, 2010 5:42 pm

Hallo, müssen Sie die Vollbild-Parameter auf der HTML-Seite, dass die SWF-Datei halten wird hinzuzufügen.
<param name="allowFullScreen" value="true" />

Hi you have to add the fullscreen parameter to the html page that will hold the SWF file.
<param name="allowFullScreen" value="true" />

Regards
Martin
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Thomsen
Posts: 10
Joined: Thu Dec 16, 2010 2:55 pm

Sun Feb 13, 2011 1:06 am

Hallo allerseits,
habe einfach kein Erfolg mit dem Eintrag <param name="allowFullScreen" value="true"/> .
Den Quelltext habe ich im Dreamweaver (s.unten) erstellt mit der eingefügten Flash-Datei in einer Tabelle.
Leider funktioniert es nicht mit "Fullscreen"
---------------------------------------------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<title>Unbenanntes Dokument</title><br>

</head>

<body>

<table width="800" border="0" align="center">
<tr>
<td height="153" colspan="3"><div align="center"></div>
<div align="center"></div>
</td>
</tr>
<tr>
<td colspan="3"><div align="center">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shoc ... n=6,0,29,0" width="800" height="500">
<param name="movie" value="meine_Flash_Datei.swf">
<param name="quality" value="high">
<param name="allowFullScreen" value="true"/>
<embed src="meineFlashdatei.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="800" height="500"></embed>
</object>
</div></td>
</tr>
<tr>
<td><div align="center"></div></td>
<td><div align="center"></div></td>
<td><div align="center"></div></td>
</tr>
</table>
</body>
</html>
---------------------------------------------------
Wer kann mir bitte weiterhelfen?

Mit Gruß, Thomas
Thomsen
Posts: 10
Joined: Thu Dec 16, 2010 2:55 pm

Sun Feb 13, 2011 11:35 am

Hello again,
ich habe eine Lösung gefunden. Ich habe die Flash-Datei in meinem CMS-Content (editierbares html) geladen. Die Darstellung im CMS-Content war zunächst negativ. Kopierte dennoch mit großer Hoffnung in meinem html-Editor von Dreamweaver. Durch Abänderung der Verknüpfung auf meine_flash_datei.swf, sowie <param name="allowFullScreen" value="true/>" verkürzt auf "allowFullScreen="true", konnte ich endlich auch in der eingebeteten html-Seite auf "Fullscreen" umschalten.
Hier der Quellcode für alle, die das gleiche Problem haben, wo dann auch letztlich in jedem html-Editor der Fullscreen funktioniert: :D
---------------------------------------------------------------------------------------------------------
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<div style="text-align: center;"><br />
<br />
<br />
<br />
<embed height="500" width="800" menu="true" loop="true" play="true" scale="showall" allowFullScreen="true" src="meine_flash_datei.swf" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed></div>

---------------------------------------------------------------------------------------------------------
Mit Gruß, Thomsen

http://www.thomkells-webdesign.de
Post Reply