Externally loaded SWFs look very fuzzy when published in FLA

Q&A about the latest versions
Post Reply
rumormill
Posts: 10
Joined: Thu Feb 14, 2008 3:21 am

Thu Feb 14, 2008 3:40 am

I want the Pano2VR-produced SWF to load into an empty movie clip (panoHolder) when I click a button.

When I click the button in the test mode, this panorama seems to load fine. But when I try to publish the project it appears fuzzy and doesn't load completely. Ideally, I want the SWF to load into the empty MC at 900 x 450.

Here's the code that's on the button, which controls the loading of the SWF into the empty MC:

on (release) {
loadMovie("panohole1.swf",_root.panoHolder);
}

Is the problem on the Flash end, or am I not choosing the correct preferences when I'm converting the files from QT MOVs to SWFs in Pano2VR?

Any help would be appreciated!
-Kori
Attachments
Here's what it looks like:
Here's what it looks like:
hole1.jpg (56.77 KiB) Viewed 4798 times
User avatar
360Texas
Moderator
Posts: 3386
Joined: Sat Sep 09, 2006 6:06 pm
Location: Fort Worth, Texas USA
Contact:

Thu Feb 14, 2008 3:07 pm

I see the loader bar which tells be that the image is still loading and what you are seeing is the "cube matrix preview". Typically shortly after the loader bar goes away.. the preview (low res version) is replaced by the final panorama which should be in focus. But it comes into focus cube faces at a time.

Specifying the 'Preview' format 3x3, 5x5, 8x8 color or grayscale is done at the time when you create the original QTVR .mov.

Of course I just might be guessing here.
Dave
Pano2VR Forum Global Moderator
Image
Visit 360texas.com
rumormill
Posts: 10
Joined: Thu Feb 14, 2008 3:21 am

Thu Feb 14, 2008 3:15 pm

Thank you, Dave. I will check that out!
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Thu Feb 14, 2008 6:11 pm

Maybe the panorama is too large and is taking a long time to download? I agree you are looking at the preview track, not the final full resolution panorama.

Regards, Smooth 8)
Image
rumormill
Posts: 10
Joined: Thu Feb 14, 2008 3:21 am

Thu Feb 14, 2008 6:48 pm

Okay, here is the project. Please click on the red flag on hole no. 1 to see the fuzzy panorama and loading bar that stays on the panorama, even though it appears to be fully loaded:

http://azstarnet.com/subsections/includ ... ftest.html

We have the panorama loading into an empty movie clip. We're using Flash 8 on Mac OSX, and viewing it in Safari.

Any help would be MUCH appreciated.
User avatar
360Texas
Moderator
Posts: 3386
Joined: Sat Sep 09, 2006 6:06 pm
Location: Fort Worth, Texas USA
Contact:

Thu Feb 14, 2008 9:47 pm

In another thread, I looked at the 'fuzzy' issue. The fuzzyness is there because you are seeing the "PREVIEW" matrix. After it completes the loading.. it gets sharper.

The movie clip is what I was talking about in the other near same topic thread. Maybe the track stop frame needs to be moved 4 or 5 frames beyond the end point to allow it to complete the loading process.
Dave
Pano2VR Forum Global Moderator
Image
Visit 360texas.com
rumormill
Posts: 10
Joined: Thu Feb 14, 2008 3:21 am

Thu Feb 14, 2008 10:20 pm

It seems the problem is pulling the external SWF file into an empty movie clip within Flash. I'm wondering if it's possible that the code produced by the latest version of the pano2vr does not like Flash 8 or AS2?

There is no stop action anywhere near the empty movie clip file, so I'm still not sure why the panorama SWF won't load completely.
User avatar
thomas
Chief Gnome
Posts: 2544
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Wed Feb 20, 2008 1:16 am

Are you trying to load a Flash 9 swf into a Flash 8 container or did you export the panorama as Flash 8? Loading a Flash 9 file into a Flash 8 project is not a good idea...
MfG, Thomas
rumormill
Posts: 10
Joined: Thu Feb 14, 2008 3:21 am

Wed Feb 20, 2008 2:40 am

No, I am trying to load the Flash 8 SWF generated by Pano2VR into a Flash 8 FLA file. The SWF does not load into an empty movie clip within Flash 8.
User avatar
thomas
Chief Gnome
Posts: 2544
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Fri Feb 29, 2008 1:30 am

Have you tired to load the movie with method described in http://gardengnomesoftware.com/wiki/Pano2VR_-_Flash_API ?
MfG, Thomas
Post Reply