Page 1 of 1

rendering out a project - taking forever

Posted: Wed Apr 24, 2013 3:19 pm
by gwindle
Hi -

As my project gets bigger, it takes longer and longer to render out the final files. Is there a way to make pano2vr just render out the new XML page and skin file instead of each image every time you make one small change to the skin? I have about 90 places in the tour and I have to wait about 10 mins for the file to render out.



Re: rendering out a project - taking forever

Posted: Wed Apr 24, 2013 6:07 pm
by Hrvoje

Good point, that's what bothers me as well.
It's (semi) OK with projects which contains 5 to 20 panos, but with bigger number of panos, it just takes a lot of time.

Maybe you could add another "Create output file" button, named "Create tour files only" which compiles only tour file(s), without panorama images.

When creating bigger projects with complicated skin, most of us are doing a lot of previews which consumes a lot of time.

Skipping creating pano images could improve compiling speed.

Or just add "Preview" (and assign F5 key to it) button right into skin editor, which should render just skin and panorama related files, without panorama main images.

What do you think?


Re: rendering out a project - taking forever

Posted: Wed Apr 24, 2013 6:53 pm
by smooth
Render your panos as multiresolution even if you only want to have a single level.
You then have the option to uncheck the create tiles box.

Regards, Smooth 8)

Re: rendering out a project - taking forever

Posted: Wed Apr 24, 2013 8:39 pm
by gwindle
Thanks for the replies - What do you mean by multi-resolution? Do you mean add a different output? Is there an option that becomes available when you do that?

Re: rendering out a project - taking forever

Posted: Fri Apr 26, 2013 12:52 pm
by Hopki
Hi gwindle,
If your output is Flash then you can select Multi Resolution.
Even if its not a giga pano you just set a single level and the level tile size to the cube face size.
Once you have remapped and created all the cube faces you can go back in the multi resolution tab and deselect Generate Files.

If you have HTML5 then when you first publish Pano2VR loads all the images. Subsequent rebuilds will happen much faster as Pano2VR detects the images in memory. However every time the project is opened Pano2VR needs load the images in to memory for the first publishing of the project. As a tip if you put the computer to sleep and do not close Pano2VR then it will not have to reload the images.

Also which will help make sure you have Smart Loading selected in the Settings/Preferences. This can be found under the Images tab and Experimental.
This will load the project much faster when you first open it.

However this is something we are looking at so hope to have a better solution in the future.
Issue #723