Tour not resizing

Q&A about the latest versions
Post Reply
kirby
Posts: 84
Joined: Thu Jun 24, 2010 6:03 am

Tue May 15, 2012 7:01 pm

I'm sure I'm overlooking something very simple here: http://bit.ly/K0cb5E

Click on "virtual tour" tab. Notice the tour is loading in an iframe, but it is not resizing. Does anyone know why it's not resizing?
User avatar
Hopki
Gnome
Posts: 11008
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue May 15, 2012 11:01 pm

Try removing this line of code from the HTML page Pano2VR generates.

Code: Select all

<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0" />
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
kirby
Posts: 84
Joined: Thu Jun 24, 2010 6:03 am

Wed May 16, 2012 2:44 pm

Thank you Hopki.

I'm not seeing that code in the tour.html file (referenced within the iframe) or on the original page's code as well. Am I missing something?
User avatar
Hopki
Gnome
Posts: 11008
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed May 16, 2012 4:05 pm

Hi,
The line of code will be found at the top of the HTML page generated by Pano2VR:
code.png
code.png (45.97 KiB) Viewed 3061 times
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
kirby
Posts: 84
Joined: Thu Jun 24, 2010 6:03 am

Wed May 16, 2012 9:56 pm

The following is copied and pasted from the tour.html file referenced within http://bit.ly/K0cb5E

Code: Select all

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

<html>

	<head>

		<meta http-equiv="Content-Type" content="text/html;charset=UTF-8">

		<title>Virtual Tour</title>

		<script type="text/javascript" src="swfobject.js">

		</script>

		<style type="text/css" title="Default">

			body, div, h1, h2, h3, span, p {

				font-family: Verdana,Arial,Helvetica,sans-serif;

				color: #000000; 

			}

			body {

				/* fullscreen */

				margin: 0px;

			}

			html, body {

				height:100%;

				font-size: 10pt;

				background : #ffffff; 

			}

			h1 {

				font-size: 18pt;

			}

			h2 {

				font-size: 14pt;

			}

			.warning {

				font-weight: bold;

			}

		</style>	

	</head>

	<body>

		<script type="text/javascript">

<!--

			var flashvars = {};

			var params = {};

			params.quality = "high";

			params.bgcolor = "#ffffff";

			params.allowscriptaccess = "sameDomain";

			params.allowfullscreen = "true";

			var attributes = {};

			attributes.id = "pano";

			attributes.name = "pano";

			attributes.align = "middle";

			swfobject.embedSWF(

				"tour1.swf", "flashContent", 

				"100%", "100%", 

				"9.0.0", "expressInstall.swf", 

				flashvars, params, attributes);

//-->

		</script>

		<div id="flashContent">

			<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /></a></p>

		</div>

		<noscript>

			<p class="warning">Please enable Javascript!</p>

		</noscript>

</body>

</html>

kirby
Posts: 84
Joined: Thu Jun 24, 2010 6:03 am

Fri May 18, 2012 5:35 am

Can you spot where the issue is arising?
User avatar
Wim.Koornneef
Posts: 218
Joined: Wed Jan 03, 2007 4:11 pm
Location: The Netherlands
Contact:

Fri May 18, 2012 7:24 am

You could try to remove the top line:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">

Often removing this line helps to solve scaling issues.

Wim
kirby
Posts: 84
Joined: Thu Jun 24, 2010 6:03 am

Wed May 23, 2012 10:03 pm

That fixed it - thanks!
User avatar
Hopki
Gnome
Posts: 11008
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu May 24, 2012 2:13 pm

Nice one Wim :-)
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply