Problems loading external swf with Firefox (SOLVED)

Q&A about the latest versions
Post Reply
User avatar
anahum
Posts: 172
Joined: Tue Apr 21, 2009 4:43 am
Location: Chile
Contact:

Tue Mar 29, 2011 10:55 pm

Hello. I'm having a strange problem. The following 2 links work perfect in Windows 7 with Safari, IE and Google Chrome, but the external swf of the skin does not loads (or shows?) if browsing with Mozilla Firefox. The problem only happens when in the web. The local tests are fine in all browsers.

--> http://skins.360panotours.com/gmgadget.html
--> http://skins.360panotours.com/txskin.html

I use Windows 7 64 bits. All my browsers with latest Flash Player.

Any idea of what can be wrong?

Thanks in advance.
Last edited by anahum on Thu Mar 31, 2011 1:32 pm, edited 1 time in total.
User avatar
Roy Reed
Posts: 161
Joined: Thu Apr 19, 2007 10:31 am
Location: London, UK
Contact:

Wed Mar 30, 2011 10:49 am

Works for me - Win7 64bit, Firefox4, Flash10.2
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Wed Mar 30, 2011 11:04 am

I looked as the gmskin previously and it loads but never could see any Google map within.
This was using Opera 11.01 browser.

I tested now with FF4 and still don't see Google Maps.

So I opened IE8.0 and yes there are Google Maps.

So your issue is not limited to FF4.

Regards, Smooth 8)
Image
User avatar
anahum
Posts: 172
Joined: Tue Apr 21, 2009 4:43 am
Location: Chile
Contact:

Wed Mar 30, 2011 10:53 pm

smooth wrote:I looked as the gmskin previously and it loads but never could see any Google map within.
This was using Opera 11.01 browser.

I tested now with FF4 and still don't see Google Maps.

So I opened IE8.0 and yes there are Google Maps.

So your issue is not limited to FF4.

Regards, Smooth 8)
Well, Roy's and your findings are opposite. This is not going to be an easy problem to solve. Thanks for testing and posting the findings.
User avatar
anahum
Posts: 172
Joined: Tue Apr 21, 2009 4:43 am
Location: Chile
Contact:

Wed Mar 30, 2011 10:55 pm

Roy Reed wrote:Works for me - Win7 64bit, Firefox4, Flash10.2
Thanks for testing and posting the findings. As you can see, will not be easy to find the problem since has different behavior in different PCs!! Your setup is very similar to mine, but in yours work. Any suggestions?
sportsnapper
Posts: 73
Joined: Tue Jun 22, 2010 10:28 pm

Thu Mar 31, 2011 12:19 am

There's a problem with the request url.

If you open the iframe page, http://skins.360panotours.com/googlemapsgadget.html and then use either firebug or I used the safari developer extensions, you can see there are many error redirects.

The request headers show the url as:

Code: Select all

 http://skins.360panotours.com/wpscripts\googlemaps5.swf?myWidth=360&myHeight=220&myZoom=15&myLatitude=52.520177&myLongitude=13.407891&myMaptype=NORMAL&myLanguage=de&myMarkercolor=GREEN&myText=Nahe%20dem%0DAlexanderplatz&myKey=ABQIAAAAE6u-2uK7LvAkr6XArUyBTxSMnU8FKpY_QTZI3Z5O3xzQGuR7lhSsu37XSwi90fga4WoKvIxmN8Nktw
If I put this into the browser it redirects to your error page, but fails.

If you change the '\' to '/' it works. Looks like a unix/MacOS/Windows translation thing to me...

perhaps try changing

Code: Select all

p2q_EmbedFlash('googlemapsgadget.swf','100%','100%','allowFullScreen','true','FlashVars',flashvars);
to

Code: Select all

p2q_EmbedFlash('./googlemapsgadget.swf','100%','100%','allowFullScreen','true','FlashVars',flashvars);
regards

Gareth
smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Thu Mar 31, 2011 8:14 am

anahum wrote:
smooth wrote:I looked as the gmskin previously and it loads but never could see any Google map within.
This was using Opera 11.01 browser.

I tested now with FF4 and still don't see Google Maps.

So I opened IE8.0 and yes there are Google Maps.

So your issue is not limited to FF4.

Regards, Smooth 8)
Well, Roy's and your findings are opposite. This is not going to be an easy problem to solve. Thanks for testing and posting the findings.
I highly doubt that! Your tours loads with FF and Opera but the Google Maps fail to load. Roy didn't mention the Google Maps because if you don't know what to expect ... well!

Regards, Smooth 8)
Image
User avatar
anahum
Posts: 172
Joined: Tue Apr 21, 2009 4:43 am
Location: Chile
Contact:

Thu Mar 31, 2011 1:35 pm

Thanks Gareth!!! Yes, the problem was the "\". With "/" works fine in all browsers!!!
User avatar
anahum
Posts: 172
Joined: Tue Apr 21, 2009 4:43 am
Location: Chile
Contact:

Thu Mar 31, 2011 1:36 pm

smooth wrote:
anahum wrote:
smooth wrote:I looked as the gmskin previously and it loads but never could see any Google map within.
This was using Opera 11.01 browser.

I tested now with FF4 and still don't see Google Maps.

So I opened IE8.0 and yes there are Google Maps.

So your issue is not limited to FF4.

Regards, Smooth 8)
Well, Roy's and your findings are opposite. This is not going to be an easy problem to solve. Thanks for testing and posting the findings.
I highly doubt that! Your tours loads with FF and Opera but the Google Maps fail to load. Roy didn't mention the Google Maps because if you don't know what to expect ... well!

Regards, Smooth 8)
You are right. Anyway, the problem is solved. The use of "\" instead of "/" in some paths was the problem.
Post Reply