HTML5 Output problem

Q&A about the latest versions
erickchen
Posts: 5
Joined: Tue Jan 18, 2011 7:02 am

HTML5 Output problem

Post by erickchen » Tue Jan 18, 2011 7:14 am

Hi everybody,

I tried to output HTML5 formate today, but when I open output file, I can not see any image in browser. it is the same situation when i upload to website, the same to IPAD.

I don't know where is the problem, anyone can help me?

http://www.5dscape.com/ipadtest/c1_vr360.html

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Tue Jan 18, 2011 2:04 pm

If you check the path to the image files you will soon find all the images are not in place.

This is there http://www.5dscape.com/ipadtest/images/c1_vr360_o_0.jpg
This isn't http://www.5dscape.com/ipadtest/images/ ... _768_0.jpg
this is being called also and isn't present http://www.5dscape.com/ipadtest/c3_vr360_out.swf
Nor this http://www.5dscape.com/ipadtest/c2_vr360_out.swf

Check your file uploads.

Regards, Smooth 8)
Image

erickchen
Posts: 5
Joined: Tue Jan 18, 2011 7:02 am

Re: HTML5 Output problem

Post by erickchen » Wed Jan 19, 2011 4:31 am

There is problem for the previous upload, some jpg were not succeeded to upload. I have not uploaded SWF file of camera 2 and camera 3, as only camera 1 is tested, and HTML5 is tested on IPAD, SWF file can not play.

Now files are uploading, but the problem still exists.

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Wed Jan 19, 2011 6:53 am

Something is wrong your end.
I "borrowed" your images and made a HTML5 Safari panorama and uploaded to my site for you to test.
http://www.omnipix.net/temp/erickchen/

It appears to work fine, only I didn't output with fullscreen .html template. Double tap the screen and it should bring it into view OK.

Make sure you keep all the path's exact. Do not rename any nor try and make overly complicated directories.
Just keep it simple and everything Pano2VR outputs should be uploaded to the server as is and complete.

Regards, Smooth 8)
Image

erickchen
Posts: 5
Joined: Tue Jan 18, 2011 7:02 am

Re: HTML5 Output problem

Post by erickchen » Thu Jan 20, 2011 7:11 am

Thanks for your help, now I had discovered the problem, it is because of the wrong file path. Now I can browse normally with skin of simplex.ggsk, but when I used the skin we created, it still has problem, no images could be seen. The following is a link, you see the skin works normally with flash version, but there could see nothing with IPAD.


http://www.5dscape.com/ipad/c1_vr360.html

User avatar
bucher
Posts: 13
Joined: Tue Dec 14, 2010 12:27 pm

Re: HTML5 Output problem

Post by bucher » Thu Jan 20, 2011 5:31 pm

Hi smooth,
you wrote about fullscreen .html template. I only find normal.html template . How can I find the fullscreen template?
Double taping the screen is not fine especially for Panotoures.
Second trouble I have is, If I output html5/css3 the browser opens a new tab, after every jump over an hot sp. in the panorama.
How can I fix this?
Example:
http://www.be-lichtung.de/inhalt.php?pageid=109

This runs fine in safari, iphone ec...but not in firefox ????

Would be greate if you could help me!!

Thanks and best wiches

Jörg Bucher

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Fri Jan 21, 2011 4:24 pm

bucher wrote:Hi smooth,
you wrote about fullscreen .html template. I only find normal.html template . How can I find the fullscreen template?
Double taping the screen is not fine especially for Panotoures.
See this thread
bucher wrote:Second trouble I have is, If I output html5/css3 the browser opens a new tab, after every jump over an hot sp. in the panorama.
How can I fix this?
Example:
http://www.be-lichtung.de/inhalt.php?pageid=109

This runs fine in safari, iphone ec...but not in firefox ????
I would need to know how you are linking your hotspots

Regards, Smooth 8)
Image

photogirl
Posts: 11
Joined: Tue Jan 25, 2011 11:47 pm

Re: HTML5 Output problem

Post by photogirl » Tue Jan 25, 2011 11:51 pm

I, too, am having a problem using custom skins with HTML5. It works perfectly in flash but just shows a white screen when I output my HTML5 with my custom skin. Have we found a resolution to this yet?
Thank You!

PS... This is really an amazing program. I am having a blast learning it!

photogirl
Posts: 11
Joined: Tue Jan 25, 2011 11:47 pm

Re: HTML5 Output problem

Post by photogirl » Tue Jan 25, 2011 11:58 pm

erickchen wrote:Thanks for your help, now I had discovered the problem, it is because of the wrong file path. Now I can browse normally with skin of simplex.ggsk, but when I used the skin we created, it still has problem, no images could be seen. The following is a link, you see the skin works normally with flash version, but there could see nothing with IPAD.


http://www.5dscape.com/ipad/c1_vr360.html

I'm having the same problem here. Is there a work around or solution?
Thanks!

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Wed Jan 26, 2011 6:05 am

photogirl wrote:I, too, am having a problem using custom skins with HTML5. It works perfectly in flash but just shows a white screen when I output my HTML5 with my custom skin. Have we found a resolution to this yet?
You don't see anything in Apple Safari Browser, just white?

Regards, Smooth 8)
Image

User avatar
bucher
Posts: 13
Joined: Tue Dec 14, 2010 12:27 pm

Re: HTML5 Output problem

Post by bucher » Wed Jan 26, 2011 12:41 pm

hi smooth,

thank you for answering.
My first problem is solved, I found the template an put it to my templatefolder. Thank´s!!

Second: i´m linking my HS with the Pointhotspot-editor in p2vr. like ID: Diele, Skin-ID: hsimage, Titel: Diele, Link: Diele.html, Target: --
I allready tried to erase the target= from all xml´s, but the problem still exists.

best regards, Jörg

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Wed Jan 26, 2011 1:47 pm

You cannot link to .html without it opening a new .html page or at least replacing it with the Target: _self attribute.
You should be linking to .xml files for HTML5

Regards, Smooth 8)
Image

User avatar
bucher
Posts: 13
Joined: Tue Dec 14, 2010 12:27 pm

Re: HTML5 Output problem

Post by bucher » Wed Jan 26, 2011 3:06 pm

Wow!!
things are so simple-sometimes. but how should i know without you?

Thanks verry much and best wiches to the other side of the globe!?

jörg

photogirl
Posts: 11
Joined: Tue Jan 25, 2011 11:47 pm

Re: HTML5 Output problem

Post by photogirl » Wed Jan 26, 2011 9:15 pm

smooth wrote:
photogirl wrote:I, too, am having a problem using custom skins with HTML5. It works perfectly in flash but just shows a white screen when I output my HTML5 with my custom skin. Have we found a resolution to this yet?
You don't see anything in Apple Safari Browser, just white?

Regards, Smooth 8)
yes, and the computer requires a restart in order to get the program to work correctly again. I am running the most current mac os.

smooth
Posts: 1493
Joined: Sat Sep 09, 2006 7:30 pm

Re: HTML5 Output problem

Post by smooth » Thu Jan 27, 2011 4:46 am

photogirl wrote: yes, and the computer requires a restart in order to get the program to work correctly again. I am running the most current mac os.
Sorry I don't do MAC. Maybe somebody else who knows where MAC fails can help you?

Regards, Smooth 8)
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 24 guests