External hosting tour

Q&A about the latest versions
Post Reply
User avatar
skyfocus
Posts: 248
Joined: Sat Jun 12, 2010 10:52 am
Location: The Netherlands
Contact:

Fri Sep 24, 2010 8:57 am

Hi,

For a customer I'm working on a virtual tour of the town Zwolle. The tour is gonna be big 100+ pano's and the idea is to host the files on my own webserver. I used the default index.html and .js file that came out of pano2vr, instead of the relative name "panoramafile.swf" I used the absolute path to the flashfiles on my server "http://www.domain.nl/Tours/panoramafile.swf".

This works fine for the first panorama, when I click on one of the hotspots to the next panorama the browser says "waiting for www.real-domain.nl". Now I tried lots of settings , also changing the hotspot links from relative to an absolute path, results are the same.

Anybody ran into this also ?

regards,

Arjan
Windows 10 Pro x64, Pano2VR pro V6 , Browser latest Firefox
Website: http://www.skyfocus.nl/
Sebastian
Posts: 209
Joined: Sun Jul 13, 2008 9:08 am
Contact:

Sat Sep 25, 2010 4:49 am

Do the hotspots use relative or absolute URL ?
Perhaps you should be consistent throughout ? Secondly, mind me asking why would you use absolute url if it runs within your domain and hosting?
User avatar
skyfocus
Posts: 248
Joined: Sat Jun 12, 2010 10:52 am
Location: The Netherlands
Contact:

Sat Sep 25, 2010 7:20 pm

Hi Sebastian,
Sebastian wrote:Do the hotspots use relative or absolute URL ?
Perhaps you should be consistent throughout ?
Both absolute and relative URL's for the hotspots don't work, same result. I usually make my tours with relative URL's. That was the first thing I thougth about to change them to absolute URL's.
Sebastian wrote:Secondly, mind me asking why would you use absolute url if it runs within your domain and hosting?
I did use relative URL's, the tour works fine that way. But the customer does not has a lot of webspace on his server. That's why Im hosting files for him, but the tour must be embedded within the website of the customer. As I said, this works for the first panorama but not the hotspots to the other panorama's. Hotspots to other URL's do work.

Is it possible that this has something to do with de permissions in the flashfile to open external media ?

Arjan
Windows 10 Pro x64, Pano2VR pro V6 , Browser latest Firefox
Website: http://www.skyfocus.nl/
User avatar
Hopki
Gnome
Posts: 9937
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Sep 25, 2010 10:25 pm

Have all the swf on your server, then use absolute url to embed starting swf on your customers website. I have done this before a long time ago. I can not remember but I think you still need to use absolute url,s but they now work. As the swf now thinks its in the web page.
Hopki
Sebastian
Posts: 209
Joined: Sun Jul 13, 2008 9:08 am
Contact:

Sun Sep 26, 2010 4:28 am

Perhaps it could be related to Adobe's cross domain policy and security permission.
It's certainty the case with loading variables across domains, it was introduced to prevent people from hijacking and loading content from outside the domain.

Please visit www.adobe.com/go/tn_14213
User avatar
skyfocus
Posts: 248
Joined: Sat Jun 12, 2010 10:52 am
Location: The Netherlands
Contact:

Mon Sep 27, 2010 11:54 am

hi,

thanks for your reply's, it helped me looking further into this.

I think I found the problem. It was a combination of two settings. Most important setting was the domain lock. I had it fixed on my own domain (the domain the files are hosted on skyfocus.nl). After removing it and use absolute URL's in the hotspots troughout the tour, it works now on the remote site.

I'm now wondering how to easy test extensions on the tour before publishing. When I have the tour local on my disk the hotspot links are pointing now outsite with those absolute URL's. Changing those links from relative to absolute all the time for 300+ hotspots is a bit of a pain.

regards,

Arjan
Windows 10 Pro x64, Pano2VR pro V6 , Browser latest Firefox
Website: http://www.skyfocus.nl/
User avatar
skyfocus
Posts: 248
Joined: Sat Jun 12, 2010 10:52 am
Location: The Netherlands
Contact:

Wed Oct 13, 2010 8:49 am

Just to make this thread complete. I've found a workaround. Not pretty but it works.

Just install a WAMP server (http://www.wampserver.com/en/) and make an alias to the directory with the actual URL you want (for example 'virtual-tour'). Edit your windows hosts file and add a line like

"www.externaldomain.nl 127.0.0."

without the quotes

Now you can access the virtual tour with http://www.externaldomain.nl/virtual-tour/ and still use de absolute URL's in your
hotspots.

Arjan
Windows 10 Pro x64, Pano2VR pro V6 , Browser latest Firefox
Website: http://www.skyfocus.nl/
Post Reply