Flash 10 Problem

Q&A about the latest versions
Post Reply
Nick_G
Posts: 3
Joined: Thu Aug 13, 2009 5:08 pm

Flash 10 Problem

Post by Nick_G » Thu Aug 13, 2009 5:48 pm

First time posting here so I'll try and get this right.

I was given a set of Pano2VR files to integrate into a Virtual Tour project that I'm doing built on Flex 3/AS3. I'm loading them dynamically, and it works fine in Flash Player 9 but Flash 10 loads without any errors. The debugger on the other hand is giving me this error on Init of the pano object:

"<Error> Error #1069: Property drawTriangles not found on flash.display.Graphics and there is no default value."

I'm guessing I've either got an out dated object from an out dated Pano2VR build or I'm missing something on how to change how the object loads into my Flex Project. Here is a list of some of the things I've tried so far:

1. Tested the Pano SWF in a stand a lone 10 player - Works fine
2. Loaded the Pano Player Directly to a SWFLoader object that exist on the stage
3. Loaded the Pano Player into a SWFLoader object that was dynamically created
4. Embed the SWF file at compile time just to see if it was a loading issue and still not working
5. Tried setting the Window Size (though I wasn't able to confirm that it was triggering right)

As you can tell I figured it was a loading issue for a while but now it seems to have something to do with a possible change in the flash.display.Graphics object. I just need some confirmation so I can go back to the photo studio who gave me these, they've told me they have the latest version of Pano2VR but I've got no way of proving it. Am I missing something? Any help is greatly appreciated

User avatar
thomas
Site Admin
Posts: 2462
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Re: Flash 10 Problem

Post by thomas » Fri Aug 14, 2009 3:37 pm

Hmmmm.... I guess the problem is that Flex thinks that the Panorama is "Flash 9 only" and switches into a Flash 9 compatibility sandbox where drawTriangles is not defined. You can try to force Flex somehow to use Flash 10 or you can disable the Flash 10 rendering in the loader init method with "vr.isFlash10=false;" as described at http://gardengnomesoftware.com/wiki/Pano2VR_-_Flash_API.
MfG, Thomas

Nick_G
Posts: 3
Joined: Thu Aug 13, 2009 5:08 pm

Re: Flash 10 Problem

Post by Nick_G » Fri Aug 14, 2009 4:34 pm

Thanks for the reply Thomas. Tried the isFlash10 switch but still no luck. But thanks for the possible lead with the rendering issue I'll look more into that.

Nick_G
Posts: 3
Joined: Thu Aug 13, 2009 5:08 pm

Re: Flash 10 Problem

Post by Nick_G » Mon Aug 17, 2009 7:49 pm

After much searching I found a solution to getting the Flex Compiler to target Flash Player 10.

Project Menu -> Properties -> Flex Compiler

In the "Additional compiler arguments:" field add in "--target-player=10.0.0" this will force the compiler to target Flash 10 when compiling which it by default (even with SDK 3.3 go fig) targets Flash 9.0115.

You can read more about the fix here:
http://opensource.adobe.com/wiki/displa ... +Player+10

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests