bug | api generated Hotspots turn invisible

Q&A about the latest versions
Post Reply
User avatar
Multimediafabrik
Posts: 33
Joined: Thu Jun 21, 2018 11:28 pm

Mon Feb 08, 2021 11:53 am

Hey,
so I'm adding hotspots via pano.addHotspot(id, pan, tilt, div). Works fine until the Hotspot moves out of the visible area. After that, they get the style "visibility: hidden", but don't change it back, once they appear on the visible area again.
How can i fix this issue?
User avatar
Multimediafabrik
Posts: 33
Joined: Thu Jun 21, 2018 11:28 pm

Mon Feb 08, 2021 3:50 pm

you can see it in action at https://testing2.360ty.world
IDs of the hotspots are "wingame1" and "wingame2" at the start node.
User avatar
Multimediafabrik
Posts: 33
Joined: Thu Jun 21, 2018 11:28 pm

Wed Feb 10, 2021 4:01 pm

i created a quickfix for it, but it isnt the most beautiful approach:

Code: Select all

pano.addHotspot(hs.id,hs.pan,hs.tilt,hs.div)
pano.addListener("positionchanged",()=>{
    if(pano.getHotspot(hs.id)){
          if(pano.getHotspot(hs.id).div.style.visibility === "hidden"){
              pano.getHotspot(hs.id).div.style.visibility = ""
          }
    }
I'm hoping for a fix soon :)
User avatar
Hopki
Gnome
Posts: 11116
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Feb 11, 2021 2:08 pm

Hi,
Thanks for the heads up, this will be fixed in the next version.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply