Page 1 of 1

Web-link is not opening by someone else

Posted: Sat Oct 17, 2020 7:24 pm
by HarryCarsa
Hi Guys, I am facing an issue with generating a web link and open the same link in different network, but that not ihappenenong for some reason, I am sure it has something to do with the settings I have tried to change some setting as shown on the tutorials amending the integrated web server settings but still no hope! any advice on how to do it is highly appreciated.

Re: Web-link is not opening by someone else

Posted: Sat Oct 17, 2020 10:05 pm
by Hopki
Hi,
I assume you are opening the web link in an iframe within the panorama.
And that page is on the same server as the panorama.
If the panorama is moved to a different server and the page will not open then it is a permission issue and the website hosting the page must allow it to be opened in an iframe if on a different server.

In a .htaccess file add: Header set Access-Control-Allow-Origin "*"
But best let the web developer do it.
Regards,

Re: Web-link is not opening by someone else

Posted: Sun Oct 18, 2020 4:43 pm
by HarryCarsa
thanks Marin, I think i miss-explain the issue or I didn't quite got what you meant,
I am trying to share a output link with my Mrs (assuming she is a client opening a link) on different internet network but still didn't open.
also I would like to mention that before contacting you guys, I ran search online in this regards and I found someone said I need to have a server or subscribe with a Pano2vr server, I am not sure if this is the case as I am not a network minded. any assistance its highly appreciated.

Re: Web-link is not opening by someone else

Posted: Mon Oct 19, 2020 6:46 pm
by Hopki
Please see: viewtopic.php?f=6&t=15184
Regards,