logic block glitch in iOS effecting scrolling text boxes

Q&A about the latest versions
Post Reply
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Fri Aug 14, 2020 7:12 pm

Hi, wondering if anyone has experienced this...

My tours have a map and slider that have logic blocks to resize when the phone is moved from portrait to landscape, if the height becomes too short to display the full content of the slider or map. This works great since the 6.1.9 update, btw. But here's the issue - my tour also has a scrolling text box that functions properly in iOS...smooth scrolling with rubber band effect at top and bottom. BUT, if the slider or map resizing is engaged by moving the device to landscape, then is returned to portrait, the text box stops sliding properly. Once a pano is selected from either the slider or map, the issue is reset, and the text box return to normal. (Please see attached video)

Here's my tour. To recreate the issue, you have to use an iOS smartphone - iPads are too big to trigger the slider or map resizing. First try the scrolling action in the "details" section in the top right corner. Then... open the slider or map in the bottom left corner > move phone to landscape so the slider or map resize > return phone to portrait and close the slider or map without selecting a pano > click on "details" button in top right corner again and try to scroll.

https://the360listing.com/apt5g/

Wondering if there's a solution to this, or just a bug.

Thanks!
Jesse
Attachments
logicBlockGlitch.mov
(9.93 MiB) Downloaded 19 times
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Sat Aug 15, 2020 8:33 am

UPDATE: just switching from portrait to landscape then back to portrait is enough to break the text scrolling. The problem doesn’t have anything to do with the map or slider. The only thing I can think of that is causing the glitch is that I have a logic block on the text box that makes it “false” when the height goes below 400 pixels (For landscape).
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Sat Aug 15, 2020 7:24 pm

UPDATE #2: this is more of an fyi for fellow pano2vr users. Using the logic block to make a text box (with scrolling text) visibility “false” may result in disabling normal scrolling on iOS systems. My workaround was to alpha the text box to 0 instead. Works fine now.
User avatar
Hopki
Gnome
Posts: 10841
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 17, 2020 8:34 pm

Hi,
Can you post into support your project so we can take a look at the issue as this is not right that you have to use an Alpha?
Go to the Help menu and then select Create Support Package, select everything which will export a large zip file.
Use a file transfer service to send it into support using the support e-mail.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Tue Aug 18, 2020 9:18 pm

Hi Hopki,

Thanks for addressing this issue. Fortunately (or unfortunately) this problem is not specific to my project. I tested it by using the simplex_v6 skin and simply added a scrolling text box, with a visible logic block: if player height is less than 400, visible = false. I had the same result on my iOS smartphone when I activated the logic block by rotating my phone to landscape, then back to portrait. The scrolling stops working until another pano is loaded. You should be able to easily recreate this issue. But the problem isn't just with player height. It might be any logic block command that makes the text box visibility false...

My original problem...was that at first I had a logic block that said: if loading = true, visible false. This logic block disabled the scrolling function on load - the scroll didn't work at all, until another pano was loaded.

I'm happy to send a project if you would still like me to, but I cannot find a help or support section.

Thanks,
Jesse
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Tue Aug 18, 2020 10:14 pm

Please ignore “I cannot find help or support section” - I thought you meant on this forum, clearly you meant inside of pano2vr :)

Still happy to create support file, though I don’t think it’s necessary. Please let me know.
User avatar
Hopki
Gnome
Posts: 10841
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 24, 2020 8:47 pm

Hi,
If it is still an issue, a working project to show the issue would be good.
So from Pano2VR Help Menu, Create Support Package.

Screenshot 2020-08-24 at 19.44.26.png
Screenshot 2020-08-24 at 19.44.26.png (55.88 KiB) Viewed 219 times

Make sure you select the skin and project file, all the files would be good so we can just open the project and see the issue.
But also make sure you give step by step to see the issue.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jmondo
Posts: 60
Joined: Thu Nov 16, 2017 11:10 am

Mon Aug 24, 2020 10:30 pm

Thanks Hopki, support package sent.
Post Reply