WebVR with oculus rift

Q&A about the latest versions
Post Reply
ich
Posts: 15
Joined: Mon Jul 06, 2020 3:20 pm

Thu Aug 06, 2020 6:48 pm

If I have understood everything correctly a tour starts directly in the "Oculus Rift" when I click the "Enter VR" button in the browser.
For this I have to install the VR glasses and allow the VR display in the browser.

Unfortunately this does not work with me.
When I click the "Enter VR" button in firefox, the "Oculus Rift" starts and tries to load Firefox. In this "loading" state the glasses get stuck.

I also tried to install "firefox reality". The program is not found by the "Oculus Rift" software.

Can someone tell me what I'm doing wrong or how I can watch a tour with the "Oculus Rift" software?

Martin
Marco360
Posts: 11
Joined: Wed Feb 19, 2020 1:02 pm

Thu Aug 06, 2020 10:42 pm

did you update the tour/pano2vr?

There was a switch from Facebook (Oculus) to not support WebVR anymore but only WebXR.
User avatar
Hopki
Gnome
Posts: 10853
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Aug 08, 2020 9:05 pm

Hi Martin,
Make sure you have. He led for updates under the help menu in Pano2VR.
Then once Pano2VR is full up to date please test again.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
bogsdolox
Posts: 16
Joined: Mon Sep 08, 2014 4:58 pm

Mon Aug 10, 2020 5:55 pm

Hi Hopki, I have a similar problem.

I have P2VR v 6.1.9 pro. I have re-built the tours with Simplexv6 but my Oculus Go headset does not show the VR version of the tour.

http://360bizphotos.co.uk/tours/woodside/index.html


Hamish
User avatar
Hopki
Gnome
Posts: 10853
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 10, 2020 6:57 pm

Hi,
I tested the Oculus Quest this morning and now with the Go, I was using our example: https://ggnome.com/samples/pano2vr_6/melbourne/
Does the example work for you?
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
bogsdolox
Posts: 16
Joined: Mon Sep 08, 2014 4:58 pm

Tue Aug 11, 2020 11:00 am

Hi, the Melbourne sample worked OK.

I have deleted the entire project and re created with the same results. All I get is the side by side view as per the screenshot attached (taken from my phone when the oculus was casting to it).

Hamish
Attachments
Screenshot_20200811-095535_Oculus.jpg
Screenshot_20200811-095535_Oculus.jpg (723.8 KiB) Viewed 570 times
User avatar
Hopki
Gnome
Posts: 10853
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Aug 12, 2020 11:06 am

Hi,
This has come up in support as well.
Testing with Pano2VR 6.1.9 with a new project it is all working as should with the Oculus Go and Quest.
Now I suspect there is something odd going on with hardware.
One customer says it's not working with the Oculus Quest, they sent me their output and testing it works fine for me on said device, now asking to see proof!
No problem as it is working, but make sure your devices are up to date.
But just to clarify iOS 13.6, Android 10, Oculus Go and Oculus Quest all running OK.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
bogsdolox
Posts: 16
Joined: Mon Sep 08, 2014 4:58 pm

Wed Aug 12, 2020 11:44 am

Hi Hopki,

My Oculus Go is fully up to date and I'm using Oculus browser v 10ish.

Tour was produced using P2VR 6.1.9.

What can I do?

Hamish
User avatar
Hopki
Gnome
Posts: 10853
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Aug 12, 2020 11:19 pm

Hi Hamish,
Just spotted your URL, you need a secure connection, so https:// otherwise the gyro will not work and you will end up with a fixed image at an odd angle.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
ich
Posts: 15
Joined: Mon Jul 06, 2020 3:20 pm

Thu Aug 13, 2020 11:22 am

Thank you very much for the answers.

I have followed all suggestions:
  • The last update of Pano2Vr is installed.
  • Graphics card drivers updated.
  • We use a secure connection
Unfortunately I still get stuck in the Firefox loading window when I click on the "Enter VR" Button
This happens on our tour:
https://ache-stallmeier.de/virtual-tour ... r_Test_01/
and on the "Melbourn Tour" of Hopki

Does anyone have any other ideas?

Martin
User avatar
Hopki
Gnome
Posts: 10853
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Aug 13, 2020 4:30 pm

Hi Martin,
If you are using an Oculus device then use the oculus browser.
Does it then work?
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
ich
Posts: 15
Joined: Mon Jul 06, 2020 3:20 pm

Thu Aug 13, 2020 5:32 pm

Hi Martin,

i have now opened "firefox" via the "oculus browser" and then started the tour.
The result is the same.
As soon as I "press" the Enter VR button, a message appears that firefox is loaded. In this state the browser freezes.
But maybe you mean another way to open Urls with the "oculus browser"?
Can I access websites directly (without opening firefox) in the oculus browser?

Martin
bogsdolox
Posts: 16
Joined: Mon Sep 08, 2014 4:58 pm

Tue Aug 18, 2020 3:50 pm

Thanks Hopki, all works with SSL certificate installed
Post Reply