$n placeholder when creating a mini tour

Q&A about the latest versions
Post Reply
etegration
Posts: 67
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Mon Aug 03, 2020 3:43 am

on my default settings, panos are output as HTML 5 and under HTML settings, output file is alwayas "output_$n\$n_html5.html"

This is ok for droplets or single panos but when linking is done, i think pano2vr 6 do not know what file name for $n to use as there are more than 1 equirectangular images imported into the tour browser.

In advance > output, droplet is using output_$n\pano.xml

how to make it use the Start Panorama as the $n name for tours?
User avatar
Hopki
Gnome
Posts: 10841
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 03, 2020 9:51 am

HI,
Have a look at this page: https://ggnome.com/doc/prefs-settings/#files
You can change the default folder and file names.

If you set the file name to $(n) then that should do it, Pano2VR may require a restart.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
etegration
Posts: 67
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Mon Aug 03, 2020 11:01 am

Hopki wrote:
Mon Aug 03, 2020 9:51 am
HI,
Have a look at this page: https://ggnome.com/doc/prefs-settings/#files
You can change the default folder and file names.

If you set the file name to $(n) then that should do it, Pano2VR may require a restart.
Regards,
thanks for the reply.

in file > settings > files, it is now output_$n
and default filename is now output_$n\$n_html5.html

in HTML settings, output file is alwayas "output_$n\$n_html5.html"
In advance > output, droplet is using output_$n\pano.xml

pano2vr6 pro has been restarted and tried multiple times but the output of the html file is always in a "output_" folder that is named "_html5.html". The $n seem to be ignored.
User avatar
Hopki
Gnome
Posts: 10841
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 03, 2020 12:04 pm

Hi
Reading this post over and over, if you're wanting to make a droplet to create a linked tour then you don't need to add placeholders in the file name?
1) Open Pano2VR, add an HTML5 output and add a skin, all with the default file names.
2) File => Save as droplet, then select Save values in the project file so you can edit it later if needed and Create a single virtual tour, select Automatically link tour nodes if your images have location data (GPS).

This will create a fully linked project using the closest node auto-linking.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
etegration
Posts: 67
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Mon Aug 03, 2020 2:31 pm

Hopki wrote:
Mon Aug 03, 2020 12:04 pm
Hi
Reading this post over and over, if you're wanting to make a droplet to create a linked tour then you don't need to add placeholders in the file name?
1) Open Pano2VR, add an HTML5 output and add a skin, all with the default file names.
2) File => Save as droplet, then select Save values in the project file so you can edit it later if needed and Create a single virtual tour, select Automatically link tour nodes if your images have location data (GPS).

This will create a fully linked project using the closest node auto-linking.
Regards,
hi again,

i am regenerating all my panoramas from 2007. thus the hassle now.

in the past, i created the html and flash file with output_$n\$n_html5.html

To save time, i am recreating all these parameters within pano2vr V6 Pro. For single panos, i put in the above parameters, not a problem at all. It generated everything nicely with the html (flash has been abandon of course) in the proper $n output folder and the $n_HTML5.html filename.

Problem arise when i am trying to generate old tours.

With the same settings plus the new settings you have advice,
in file > settings > files, it is now output_$n
and default filename is now output_$n\$n_html5.html
The tour is having issue. Everything is generated nicely in the output_$n folder name. Only the html file is left out and create in it's own "output_" folder that is named "_html5.html". Thus why i am wondering why the $n is ignored when creating then outputing a tour.
etegration
Posts: 67
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Mon Aug 03, 2020 2:44 pm

ok. managed to try some test when the kids went to nap.

im very sure it's the below setting in Output Panel > HTML > Output File settings.

Image

It is not listening to the $n settings that is set and will ignore it when it is a Tour that has multiple nodes. pano2vr do not know which file to use as $n.

When a single pano is output with the same settings, the $n_HTML5.html file is created inside output_$n nicely and the pano opens when the pano is exported successfully through the local web server.
etegration
Posts: 67
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Wed Aug 05, 2020 8:01 am

no solution i guess?
User avatar
Hopki
Gnome
Posts: 10841
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Aug 07, 2020 4:01 pm

To check my understanding, you have an old tour.
So I take it you have a folder that has the panoramas, skin and the p2vr file right?

If so just make a droplet, for a single tour.
If it contains just a Flash output then it can't.
I can not understand what the issues are.

Or at least it is not clear to me.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply