Google maps not showing in Tour Map

Q&A about the latest versions
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Wed Aug 26, 2020 10:53 am

I'm not sure if this is relevant but the Project number in the error pop-up is different from the one in my Google Cloud Platform? I have refreshed the API key and replaced it in Pano2VR 6.1.9 on Mac

I have no quota errors.
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Aug 27, 2020 11:30 am

Hi Jono,
Have a look at your Google account, have you exceeded your payment?
Regardless of API key do you have the funds to cover the usage, does anyone else have access to your key?
If you remove your own API key from Pano2VR's Preferences/Settings, then close and reopen do you see the Map?
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Fri Aug 28, 2020 10:12 am

Thanks for your reply again.

I have enough funds, the API on google isn't showing any errors and no fund alerts and in fact zero balance.

If I remove my own API and restart the prog, the map is still grey as attached? I've re-installed the software, using the latest version, have no issues with google on Chrome etc, have nothing active or blocked in firewall.
Screenshot 2020-08-28 at 09.09.26.png
Screenshot 2020-08-28 at 09.09.26.png (890.63 KiB) Viewed 347 times
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Aug 28, 2020 8:34 pm

Then all I can think of is a firewall that prevents Pano2VR to connect to the Google API.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Fri Aug 28, 2020 9:40 pm

Hello, Thanks for your reply. good news, I completely disabled the firewall on the mac and Google maps now show without an API. HURRAH, thank you!
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Aug 28, 2020 10:39 pm

Hi Jono,
Now use your own API key.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Sat Aug 29, 2020 10:52 am

And once again, the map is grey. Firewall completely disabled. I have removed the API and still grey, put it back, still grey. Ahhhh

I am getting this error but no errors and it's only had 4 API requests! Billing linked fine and not over quota.

Error transferring https://streetviewpublish.googleapis.co ... geSize=200 - server replied: Too Many Requests

{
"error": {
"code": 429,
"message": "Quota exceeded for quota metric 'Read and write requests' and limit 'Read and write requests per minute per user' of service 'streetviewpublish.googleapis.com' for consumer 'project_number:369087276736'.",
"status": "RESOURCE_EXHAUSTED",
"details": [
{
"@type": "type.googleapis.com/google.rpc.Help",
"links": [
{
"description": "Google developer console API key",
"url": "https://console.developers.google.com/p ... credential"
}
]
}
]
}
}
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 31, 2020 1:46 pm

Hi,
Ok, to check my understanding, when you remove your own API key it now works as your Firewall is no longer blocking Google.
Add your own Key and it fails.

What we have seen in the past is API keys just brake!
Login to your Cloud Console, delete the API Key and create a new one adding the required three APIs to the key.

Try this, does it help?
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Tue Sep 01, 2020 10:30 am

To confirm. When I remove the API and restart the software, the screen is still grey. My firewall is completely off and I am on Mac OS 10.15.6

I have refreshed the API as well as deleted it and created a new one with the three required API's assigned to the key as in the guide.
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Sep 01, 2020 5:20 pm

OK,
You said,
"Thanks for your reply. good news, I completely disabled the firewall on the mac and Google maps now show without an API"
So has this now changed?
I am getting lost as up until now this pointed towards your API key.

So you are saying with or without the API key in the Preferences/Settings you do not see the Tour Map, just to confirm not the Map Element Map.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Jono
Posts: 17
Joined: Mon May 18, 2020 5:20 pm
Location: Nottingham

Tue Sep 01, 2020 6:11 pm

Correct I did say that briefly for maybe 10 minutes and then it went back to grey. WIth and without anything in the API field. Google Maps of all types is completely grey. I still have no firewall activated.

Do you suggest I remove the programme and re-install? If so, are there any hidden files I need to remove to ensure a clean install on Mac?
User avatar
Hopki
Gnome
Posts: 10825
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Sep 01, 2020 6:32 pm

Hi,
This is a local problem and I am not convinced its Pano2VR, more something stopping Pano2VR for communication with Google.
But to do a clean install you need to remove the app by dropping it into the bin.
Then select:
Library => Application Support => delete the folder GardenGnomeSoftware.

Then select:
Library => Preferences => delete the file: com.gardengnomesoftware.pano2vr.plist.

This will remove everything so make sure you have your license key to hand and you have saved any custom skins.
May be worth doing a Time Machine back up before you start just encase you forget to do something.
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply