Animation Trigger problems

Q&A about the latest versions
Post Reply
VIRTUALIZE
Posts: 4
Joined: Mon Feb 06, 2017 12:48 pm

Tue May 19, 2020 1:32 am

I've been asked by a client to create an animated sequence, triggered by a mouse click.
I thought this would be pretty straightforward.. but I have been having all sorts of problems...

I have created a sequence OK... and thought I'd be able to trigger this with a simple action :
Mouse Click >> Auto Rotate >> Start Animation >> My Sequence

However...apparently because animations are associated with auto-rotate functionality... this action starts auto-rotate for the CURRENT node (not the animation I want).

If I use the following actions :
Mouse Click >> Open next Pamorama >> NodeName
Mouse Click >> Auto Rotate >> Start Animation >> My Sequence

It goes to the node at the start of the animation, and starts the animation but stops it 1/2 second or so into the animation.

I have tried various other actions and combinations using variables and different triggers and the best I have come up with so far is :
Mouse Click >> Open next Pamorama >> NodeName
Mouse Leave >> Auto Rotate >> Start Animation >> My Sequence

Which sort of works... but isn't very user friendly

I presume I am just misunderstanding how animations work... but any suggestions on a simple way to trigger a specific animation sequence from a mouse click?
VIRTUALIZE
Posts: 4
Joined: Mon Feb 06, 2017 12:48 pm

Thu May 21, 2020 8:48 am

Hmm.. suggestions anyone ??
VIRTUALIZE
Posts: 4
Joined: Mon Feb 06, 2017 12:48 pm

Mon May 25, 2020 9:48 am

I'm still looking or a solution to this... any ideas ??
Post Reply