Google - This page can't load Google Maps Correctly ERROR

Q&A about the latest versions
Post Reply
User avatar
RobH2
Posts: 8
Joined: Mon May 21, 2018 10:49 am
Location: Baltimore, MD USA
Contact:

Sun Feb 02, 2020 9:52 pm

Hi,

I haven't used Pano2VR in 6-months or so and now have a project. I went to the Home site and saw there was an update (6.1.2) and installed it.

When I launch, I get an error in the 'Tour Map'. It's a white error box saying "This page can't load Google Maps correctly" and the background is tiled with "For development purposed only." The box has and "OK" button but it does not work so the box is persistent. See the attachment.

What can I do to correct this? I searched the forum and found no discussion about it.
Attachments
GoogleEarthERROR.jpg
GoogleEarthERROR.jpg (265.83 KiB) Viewed 710 times
User avatar
Tony
Posts: 985
Joined: Mon Feb 15, 2010 6:54 am
Location: Adelaide, South Australia
Contact:

Sun Feb 02, 2020 11:14 pm

Hi,

In order to use Google Maps in the Tour Map, or to add Place IDs for Street View, or to add a Google Map in the skin, you will need a Google Maps API key. Google requires this key for anyone wishing to use/embed their Maps JavaScript API (Google Maps).

Just a tip, rather than just checking the forums there is a bunch of information in the Documentation section of the web site.

Check this out: https://ggnome.com/doc/pano2vr/6/google-api/

More information: Updates to Google Maps APIs Standard Plan https://cloud.google.com/blog/products/ ... -to-google

cheers,

Tony
Tony Redhead | Panoramic Photographer | mobile: +61438501002 | website: http://tonyredhead.com - http://redsquare.com | roundme: http://round.me/@tonyredhead | instagram: https://www.instagram.com/tonyredhead/
User avatar
RobH2
Posts: 8
Joined: Mon May 21, 2018 10:49 am
Location: Baltimore, MD USA
Contact:

Sun Feb 02, 2020 11:28 pm

You 'da man Tony. I appreciate this. :D
Post Reply