Animated hotspot node & image | issues wt Chrome Android -SOLVED

Q&A about the latest versions
Post Reply
User avatar
Julien
Posts: 18
Joined: Sat Sep 28, 2019 7:05 pm

Animated hotspot node & image | issues wt Chrome Android -SOLVED

Post by Julien » Sun Sep 29, 2019 11:59 am

Hello everyone,
This is my first tour and post with Pano2vr. I'm an experienced tour builder with Panotour...

I used this awesome tuto to create my animated hotspots https://www.youtube.com/watch?v=3h449wL5oJI
My tour: https://www.360production.asia/360-samp ... index.html

Using a laptop onto Chrome, FF, and so, all hotspots works fine
Using my smartphone and tablet (both Android) onto Chrome, the hotspots come invisible but clickable. Works fine onto FF
My devices frameworks and apps are updated...

I looked up onto the forum, can't believe I'm the only one having this issue... :mrgreen:
Is it something related with Krpano?
Thanks & awaiting for feedback
Last edited by Julien on Wed Oct 09, 2019 3:41 pm, edited 1 time in total.
Pro version
Mac

User avatar
1uv3
Posts: 339
Joined: Thu Sep 20, 2018 10:18 pm

Re: Animated hotspot node & image | issues wt Chrome Android

Post by 1uv3 » Sun Sep 29, 2019 9:45 pm

Hi!

Welcome to the forum :-)

I use the same animated hotspots all the time in my tours with no issues so not sure what may be going on. Have you tried creating a project skin without anything BUT the animated hotspot? Have to eliminate as many variables as possible to narrow it down.
Is it something related with Krpano?
What do you mean by this?
Creative expression is the Universe's only way of experiencing every configurative atomic possibility capable within a finite Universe.

User avatar
Julien
Posts: 18
Joined: Sat Sep 28, 2019 7:05 pm

Re: Animated hotspot node & image | issues wt Chrome Android

Post by Julien » Mon Sep 30, 2019 6:53 am

Hi there!

The step by step animated tuto by Hopki works just great online with all my browsers.

I've fixed/tricked one of my issues but still a wired one is remaining, using Chrome with my GSMs android (don't have an apple gsm)
New test project on blank skin https://www.360production.asia/360-samp ... index.html

Hotspots node are doing ok now.
My previous animated hotspot was made using my custom svg files (giving me a problem onto Chrome).
So for this new test project, I did code the animated hotspot with the skin interface (I'm getting better :) ) and it's all good.

Hotspot image is not ok
*I used the 'image pop up silhouette component', friendly replaced the default image hotspot to mine (svg), added a variable & timer to make it animated.
Only Chrome so far onto my GSMs is making invisible my custom hotspot, but the image attached to it will pop if you know where to click! (same problem I had with my previous custom image nodes, invisibles but actives)
*note: Using this same component without replacing the default image hotspot to mine (plus a variable & timer), Chrome works fine.

So is there a trick to use custom hotspot images?
Cheers!

PS: forget about the Krpano, i used it with PTP for some other things.
Attachments
Capture d’écran 2019-09-30 à 10.47.12.png
Capture d’écran 2019-09-30 à 10.47.12.png (189.83 KiB) Viewed 675 times
Last edited by Julien on Thu Oct 03, 2019 3:38 am, edited 1 time in total.
Pro version
Mac

User avatar
1uv3
Posts: 339
Joined: Thu Sep 20, 2018 10:18 pm

Re: Animated hotspot node & image | issues wt Chrome Android

Post by 1uv3 » Mon Sep 30, 2019 9:24 pm

*note: Using this same component without replacing the default image hotspot to mine (plus a variable & timer), Chrome works fine.
Have you tried swapping out the hotspot image with anything else (png, jpg, gif, etc...) other than your svg file? If so what were your results? Also, does your svg image work anywhere else within the skin? Does the svg appear after publishing the tour if you simply add it do the skin with no logic or action? I ask because there are different types of svg and I noticed early on that Pano2vr does not play well with all of them.
Creative expression is the Universe's only way of experiencing every configurative atomic possibility capable within a finite Universe.

User avatar
Julien
Posts: 18
Joined: Sat Sep 28, 2019 7:05 pm

Re: Animated hotspot node & image | issues wt Chrome Android

Post by Julien » Wed Oct 02, 2019 6:47 am

Hey 1uv3
Okay it's solved & good. Thank you for the tips :)

It was my svg file giving me an issue on my Android using Chrome.
I created it using Ps cc 2019, 'export under' --> svg. Works with FF but not with Chrome (I don't know much about svg files)
Instead I used Affinity Photo, 'save as' --> svg. All good!

Newbies: :mrgreen: If you're trying to fix a problem found within your devices, Use the built-in web server. No need to upload a test project onto the FTP for checking with your devices. So convenient!! https://www.youtube.com/watch?v=mA2DwTaKCbk (5.30)

Note: As a post author it will be nice to have a button e.g 'this post is solved'. A check mark to be displayed with the post onto the forum home page.
Pro version
Mac

User avatar
1uv3
Posts: 339
Joined: Thu Sep 20, 2018 10:18 pm

Re: Animated hotspot node & image | issues wt Chrome Android

Post by 1uv3 » Wed Oct 02, 2019 7:35 pm

Hi,
Hey 1uv3, Okay it's solved & good. Thank you for the tips :)
No problem. Glad you were able to get the issue resolved :-)
Creative expression is the Universe's only way of experiencing every configurative atomic possibility capable within a finite Universe.

User avatar
Hopki
Gnome
Posts: 9721
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Animated hotspot node & image | issues wt Chrome Android

Post by Hopki » Tue Oct 08, 2019 5:12 pm

Hi Julien,
You should be able to go back to your post and add to the title of the topic, so add "Solved".
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests