Flat image 'show all' problem on mobile

Q&A about the latest versions
Post Reply
nich008
Posts: 18
Joined: Mon Apr 13, 2015 9:50 pm

Fri Sep 27, 2019 3:27 pm

I have a flat input image with field of view set to 'Show All'. I want the entire image to be visible when it loads, so I've set the default view to be as zoomed out as possible.

When published:
On the desktop (Chrome on Win 7) everything works as expected - the image is initially completely visible with grey borders top and bottom. You can zoom in and back out to original FoV.

On mobile however, (Safari on IOS 12.4 or Chrome on Android 5.1) the image loads OK, but rather than zoom in on pinch it kind of 'snaps' in, and the image will not return to the original all-visible FoV unless it's reloaded.

This makes 'Show all' unusable in my context, and I'm hoping there's a solution. Any thoughts?

Thanks
John
User avatar
1uv3
Posts: 340
Joined: Thu Sep 20, 2018 10:18 pm

Sat Sep 28, 2019 8:56 am

Got a link so we can take a peak at what's going on?
Creative expression is the Universe's only way of experiencing every configurative atomic possibility capable within a finite Universe.
nich008
Posts: 18
Joined: Mon Apr 13, 2015 9:50 pm

Wed Oct 02, 2019 2:23 pm

Thanks for your interest. Here's an illustration of the problem, link below:

Flat test image with a red border to highlight the issue.
(I need flat images to incorporate full screen artistic street plans)

Input image is of type 'Flat'
Default View is zoomed right out so the red border is visible
Max Field of View is set to 'Show all'


Load on a desktop browser (I've tested on Chrome on Win 7):

On landscape desktop and landscape mobile devices all works perfectly - the image loads as completely visible and you can zoom in and back out.

Load on a mobile device (I've tested on Safari on IOS 12.4 or Chrome on Android 5.1, both have the same problem):

On portrait mobile the image initially loads fine - the borders are visible.
But if you make a pinch or un-pinch(?) gesture the image jumps to a much more zoomed-in state and won't zoom out again.

Any thoughts?

http://nich008b01.s3-website.eu-west-2.amazonaws.com/

Thanks
John
User avatar
Hopki
Gnome
Posts: 9937
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Oct 08, 2019 4:47 pm

Hi John,
I have added a bug report.
Regards,
Hopki
nich008
Posts: 18
Joined: Mon Apr 13, 2015 9:50 pm

Tue Oct 15, 2019 11:45 am

Thanks Hopki
nich008
Posts: 18
Joined: Mon Apr 13, 2015 9:50 pm

Thu Dec 19, 2019 3:45 pm

Thanks Gnomes, I can confirm that this is fixed in 6.1.2
User avatar
Hopki
Gnome
Posts: 9937
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Dec 19, 2019 5:14 pm

:D
Post Reply