Info Point Hotspot - custom images

Q&A about the latest versions
Post Reply
Westlake
Posts: 20
Joined: Wed Aug 09, 2017 12:42 pm

Info Point Hotspot - custom images

Post by Westlake » Thu Aug 29, 2019 6:17 pm

I am using Pano2VR 6.1 beta 3b

For the tour I am working on, we need to use a number (~10) of different icons for info point hotspots, denoting the type of element we are providing info for. This means I can't just change the icon in the skin.

My version of Pano2VR includes a "Custom Image" parameter in the Properties for the point hotspot, which is not shown in the documentation page
https://ggnome.com/doc/pano2vr/6/hotspots-point-props/

I have added the images to each of the point hotspots in Pano2VR. On my laptop, the custom icons appear as planned but when I create the package, they are not included and don't appear when the tour viewed on the website. Is there a setting I can change so these custom images will be included in the .ggpkg?


Thanks for any assistance you can provide!

User avatar
Hopki
Gnome
Posts: 9446
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Info Point Hotspot - custom images

Post by Hopki » Mon Sep 02, 2019 10:02 pm

HI,
To add custom images outside of Pano2VR, use the Assets feature as found at the bottom of the Advanced tab of the HTML5 output.
What this will do is place a file or folder in a folder called assets.
As an example, an image called, image.png when added to Pano2VR via the assets will have the path:
assets/image.png
If you added a folder with this image inside called hotspot_images, then the path would be:
assets/hotspot_images/image.png

As Pano2VR knows about these images and folders they will get included in the package.
Regards,
Hopki

Westlake
Posts: 20
Joined: Wed Aug 09, 2017 12:42 pm

Re: Info Point Hotspot - custom images

Post by Westlake » Wed Sep 04, 2019 10:43 pm

Thanks, Hopki!

I used the Assets feature as you suggested and sure enough, the source folder was copied to the output/assets folder as you said it would, however, I am still doing something wrong as the custom icons still are not appearing.

In specifying the source for the custom image I have tried 2 approaches
  • Selecting the image from the folder that was copied to the assets folder, which obviously creates a different file path than you indicated
  • Selecting the image from the subfolder in the assets folder, creating the path as you described
Both approaches get the same result:
https://westlakemedia.ca/verge-yard-tour-1st-draft/

All links are currently to the assets folder

Sorry for being a PIA, but I seem to have still done something wrong here

User avatar
Hopki
Gnome
Posts: 9446
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Info Point Hotspot - custom images

Post by Hopki » Thu Sep 05, 2019 1:04 pm

Hi,
Looking at the web error console it is saying it can not find the image at location: https://westlakemedia.ca/verge-yard-tou ... ctor_7.svg

Check to see if this path is correct.
What is in your external loaders URL?
Regards,
Hopki

Westlake
Posts: 20
Joined: Wed Aug 09, 2017 12:42 pm

Re: Info Point Hotspot - custom images

Post by Westlake » Thu Sep 05, 2019 3:25 pm

That is the URL that results from the relative path from my loading the image from the source folder.

If you go to the back yard (target in the trees to the left, then the next target), there is a missing image for "Solar Hot Water" The path for that is to the assets folder

The files are uploaded using the Wordpress uploader.

Thanks for your help with this!

User avatar
Hopki
Gnome
Posts: 9446
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Info Point Hotspot - custom images

Post by Hopki » Thu Sep 05, 2019 4:27 pm

Can you send me your package?
Use my e-mail if it's too large for the forum.
Regards,
Hopki

User avatar
Hopki
Gnome
Posts: 9446
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Info Point Hotspot - custom images

Post by Hopki » Thu Sep 05, 2019 10:10 pm

Hi,
I have just tested, in the external loader set the path to the image.
So if your image is called ht_image.jpg, and you used the assets to load the image, the path will be assets/ht_image.jpg
Regards,
Hopki

Westlake
Posts: 20
Joined: Wed Aug 09, 2017 12:42 pm

Re: Info Point Hotspot - custom images

Post by Westlake » Fri Sep 06, 2019 3:33 pm

I'm confused. I look at the path for the largest image on the front (see attached screenshot) is output/assets/Custom/filename, which is the relative path I would expect to work, sans the "output" directory. Are you saying I set that incorrectly, or that the uploader changed the path to one that doesn't work? If it is the uploader, how do I work around that so my external images work?
Attachments
Screenshot 2019-09-06 07.22.19.png
Screenshot 2019-09-06 07.22.19.png (4.13 MiB) Viewed 175 times

User avatar
Hopki
Gnome
Posts: 9446
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Info Point Hotspot - custom images

Post by Hopki » Fri Sep 06, 2019 6:38 pm

Hi,
As said,
So if your image is called ht_image.jpg, and you used the assets to load the image, the path will be assets/ht_image.jpg
When you publish Pano2VR creates an assets folder and places the image in there.
To check this, publish your project and open the output.
Do you see the assets folder?
Inside this folder do you see your file?
If so the path to this image in the skin will be: assets/file.jpg

You say your path is: output/assets/Custom/filename
So in the output folder, you have an assets folder and inside that, another folder called custom and then the file.
The path in the external loader will be: assets/Costom/file.jpg

Note, I see you're using a capital C for Custom.
So make sure you have this in the external loader, once uploaded to a server capitalisation matters. Not so much when viewed locally.
Regards,

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 32 guests