Solved: Firefox 68 loading issue | Local index.html wont't load context | Panorama doesn’t load

Q&A about the latest versions
Post Reply
User avatar
FLangmann
Posts: 7
Joined: Thu Aug 15, 2019 5:06 pm

Fri Aug 16, 2019 3:29 pm

Hi guys, dear Panoramaheads,

Thanks for adding me to the forum Hopki!

I was a bit of surprised, since a few weeks I wasn’t able to run local code files located in the “output” folder.
index.html won’t load the context with the good old firefox.

As I thought they added a new security feature in, which is blocking local initiated codes, I found this here:
CVE-2019-11730: Same-origin policy treats all files in a directory as having the same-origin
(Source: https://www.mozilla.org/en-US/security/ ... 2019-11730)

And here is what I found to get back to the local panorama party:

You can leverage this restriction by going to about:config url and then uncheck: "privacy.file_unique_origin" boolean value.
Source: https://stackoverflow.com/questions/569 ... o-override

Success,

Frank
Last edited by FLangmann on Wed Oct 16, 2019 11:12 am, edited 1 time in total.
User avatar
Tony
Posts: 999
Joined: Mon Feb 15, 2010 6:54 am
Location: Adelaide, South Australia
Contact:

Sat Aug 17, 2019 2:55 am

Hi Frank,

Nice find :D

Tony
Tony Redhead | Panoramic Photographer | mobile: +61438501002 | website: http://tonyredhead.com - http://redsquare.com | roundme: http://round.me/@tonyredhead | instagram: https://www.instagram.com/tonyredhead/
User avatar
FLangmann
Posts: 7
Joined: Thu Aug 15, 2019 5:06 pm

Wed Oct 16, 2019 11:09 am

Thank you Toni, I was a little bit concerned of the unwilling firefox behavior. I am so lucky that the browser now is so safe, unwilling to execute local java's. :lol: next step of firefox security might be the duty to use a safety helmet and a harness while using the browser.
Tawrank
Posts: 10
Joined: Fri Feb 15, 2019 9:28 pm

Tue Nov 12, 2019 9:10 am

I had the same problem, couldn´t open all my tours anymore - now I´m so happy to find this issue here and to be able to solve it immediately - thanks a lot ! Do you know any solution for safari ?

Tawrank
User avatar
Hopki
Gnome
Posts: 10859
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Nov 13, 2019 11:03 pm

Hi Tawrank,
For Safari on the Mac.
• Select, Safari => Preferences...
• Select the Advanced tab => then select Show Develop menu in menu bar

You will now see the new menu item, Develop between Bookmarks and Window.
Select the Develope menu then select Disable Local File Restrictions.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Neal
Posts: 177
Joined: Thu Dec 12, 2013 11:14 am
Contact:

Mon Aug 24, 2020 10:06 pm

Is there a way around this in either Chrome or Edge??

Or can you point me at the config setting for the P2VR server?
User avatar
Hopki
Gnome
Posts: 10859
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Aug 24, 2020 10:29 pm

Hi Neil,
Please see this page: https://ggnome.com/doc/server-using/
You can also use the desktop app, https://ggnome.com/ggpkgviewer/
Regards,
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
Roy Reed
Posts: 164
Joined: Thu Apr 19, 2007 10:31 am
Location: London, UK
Contact:

Tue Aug 25, 2020 12:38 pm

You can do it on Chrome, but it's much more fiddly.
  • Close all running instances of Chrome.
  • Start a command prompt / terminal window. (On Windows, type Command Prompt in the Search box, and then, in the list of results, click Command Prompt.)
  • Find the Chrome executable folder.
  • In the command prompt terminal, start the Chrome executable with the command line:
    path_to_chrome/chrome --allow-file-access-from-files
  • Chrome will open, then you can drag and drop the HTML file onto it, or open it from the address field. (Or you can add the path_to_html_file after --allow-file-access-from-files.)
For me on Win10 path_to_chrome is C:\Program Files (x86)\Google\Chrome\Application\
Post Reply