Anchoring Not Working As Expected?

Q&A about the latest versions
Post Reply
User avatar
1uv3
Posts: 219
Joined: Thu Sep 20, 2018 10:18 pm

Anchoring Not Working As Expected?

Post by 1uv3 » Sat Aug 10, 2019 11:46 pm

Hi All,

This is such a simple concept that one would think that their logic was completely sound when attempting to execute it......but I am again mistaken :-)

When I set the anchors for a child element, the anchors are not adhering to the anchor spots of the actual parent container itself. Instead they are "remembering" where they are anchored within the parent container BEFORE the container size is changed and they stay in that same anchored position without responding to the responsive container size. Even as I write this it does not seem clear so the easiest way to explain this is with a video, so here it is:

https://youtu.be/yEqaUB2Bk_E

If the child elements did what I expected them to do in the video (adhere to anchor location within container regardless of how the container is resized) then this would make life 1,000 X easier for everyone when developing skins that are responsive.

I seem to remember touching on this issue here in the forums when I first started using Pano2vr. There is of course a workaround but it is INSANELY labor intensive and time consuming especially when you have hundreds of elements that you have to rework.

With the new update their may be an easy solution but I have not found it because I can find no new documentation on usage of all the new features that have been added.

Any suggestions? Thanks!
Creative expression is the Universe's only way of experiencing every configurative atomic possibility capable within a finite Universe.

User avatar
Hopki
Gnome
Posts: 9363
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Anchoring Not Working As Expected?

Post by Hopki » Sun Aug 11, 2019 12:24 pm

Hmmm,
For me, this is working as expected.
Can you post a skin with a simple test showing the issue?
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: Bing [Bot] and 13 guests