Page 1 of 1

YouTube & VR Mode?

Posted: Fri Jul 19, 2019 5:26 am
by 1uv3
Hi All,

I have added a YouTube video to a television screen within a node. The video displays/plays fine on desktop and mobile devices however it does not show up when in VR mode. I have an Oculus Go and the video does not show at all when in VR Mode.

Is there a setting that I'm missing to get it to show up?

Thanks!

Re: YouTube & VR Mode?

Posted: Sun Jul 21, 2019 1:45 am
by 1uv3
I've also notice that iframes do not work either. Is this is a settings issue or is Pano2vr just not there yet? and if the case is the latter then is there a way to hack it?

Thanks!

Re: YouTube & VR Mode?

Posted: Fri Jul 26, 2019 6:45 pm
by Hopki
Hi,
Skins are not supported in WebVR so it will not show.
However, Embedded video does and this is not using a skin.
check out this blog post: https://ggnome.com/blog/pano2vr-605-rel ... o-tutorial
Regards,
Hopki

Re: YouTube & VR Mode?

Posted: Sat Jul 27, 2019 3:38 am
by 1uv3
Hi Hopki,

Thanks for the info :-) I know about embedded video, this was for embedding a youtube channel into a tv set where the user can in real time select different videos to play from a playlist.....so a static video would not work for this. This works fine on desktop, just doesn't transfer to VR mode.

Is there a hack for this that will enable me to watch YouTube videos in VR mode by replacing the embedded image with embedded YouTube?

Thanks for all your hard work and great video tutorials!!!

Re: YouTube & VR Mode?

Posted: Fri Aug 09, 2019 9:46 pm
by Hopki
Thanks for all the kind words, its a team effort so will pass on your kind words.
At the moment pinned video has to be a local file.
Sorry.
Regards,
Hopki

Re: YouTube & VR Mode?

Posted: Sat Aug 10, 2019 9:15 pm
by 1uv3
No worries, I'm sure that we will get there at some point :-) Thanks Hopki!