Pano map distortion when mouse has focus

Q&A about the latest versions
Post Reply
User avatar
Brian
Posts: 36
Joined: Thu Mar 08, 2007 7:19 pm
Location: Glasgow, Scotland
Contact:

Pano map distortion when mouse has focus

Post by Brian » Sun Sep 07, 2008 11:06 pm

This is a smallish problem, but takes a while to explain and also stops me using Pano2VR even in Flash 8 mode, so is fatal.

As I still use AS2, in order to explore moving from Pano2QTVR v6.6 to Pano2VR I exported some Flash panoramas in Pano2VR to Flash 8, and the panoramas themselves work perfectly from a rendering standpoint, in my same code v6.6 as above.

The issue I have here is to do with mouse focus in the panorama as ILLUSTRATED by the controller. The controller appears to work fine in itself. But I also use a map (with the red dots, just as in Thomas's park demo, see http://www.briansutton.net/dpg for my latest tour, still wholly built with pano2qtvr66 version).

If I use the Flash 8 export from Pano2VR instead, everything is OK except that when you see the controller change from "normal" to "bold" when mouse focus is gained anywhere in the pano, my red map dots also change, and it looks awful. I have a public page up that shows that, at http://www.briansutton.net/dpg_test. On testing I find that the presence or not of the controller makes no difference - the mouse focus is what cause the effect, not the controller itself which is just ILLUSTRATING the focus. When I remove the controller from the site files, this still happens.

In this site, panoramas 7 to 20 are all pano2VR Flash 8 versions. Note that Panorama 6 is a pano2VR Flash 9 one that doesn't appear at all. All the rest - (1-5 and 21-36) are built with pano2qtvr66 (i.e. copies of the main site).

You will see the site opens with panorama 1 and all is well, and as you move using the arrows thru' panoramas 2, 3, 4 and 5 it's OK. Then Panorama 6 predictably fails (because it would need an AS3 code to render it, this isn't the issue here). But GO BACK to pano 5 a moment to see that this is still OK, as are 1-4.

Now go forward to panorama 7 and you see the red dot, mouse focus problem. whenecer the mouse is over the pano, the map dots are affected just as the controller text is. This is the same for panoramas 8 - 20. But now go back to any of Panoramas 1-5 or 21 - 36 and they now also exhibit the red dot problem when they didn't before. Odd, huh!?

You will see, then, that now the red dot effect affects ALL the panoramas, no matter which version they were built with - this was the common factor with an old rendering problem last year that I repoerted to Thomas that led to the release of Pano2QTVR versions 6.5 and 6.6. - if one pano was wrong, ALL the panoramas ended up in the wrong place because of a positioning issue caused by the API. It seems odd to me...

...but Thomas will probably know what is going on. The map dots change from full, circular dots to a slightly irregular shape moved down and right by a pixel or two when focus is gained in the main panorama.

It's not something that my own code can deal with, it must be in the way the .swf is generated, or its API. Could Thomas look at this and let me know if I CAN avoid it. When all the panoramas are built with pano2qtvr66, this doesn't happen at all.

I doubt if this problem is something anyone else has noticed (you would have to be using maps, dots and Pano2VR), but apologies if my ignorance about Pano2VR leads me to ask a question to which the answer is already obvious!

Afterthought problem!

Finally - How can the .png that is created as a hotspot file by pano2qtvr66 (and pano2VR?) be used to show a hotspot image? I've tried all sorts of ways (e.g. pasting an image into the .png) but all I can get in the Pano is the text for the hotspot and an invisible hot area. Where does the .png have to be? What does it have to be called? Can it do this anyway? Of course, if links to .swf as well as .mov could be set to hotspots, hotspot setting life would be simple, but I still can't get a hotspot image to show at all!

Best regards,

Brian

User avatar
thomas
Chief Gnome
Posts: 2537
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Re: Pano map distortion when mouse has focus

Post by thomas » Tue Sep 09, 2008 11:49 am

The problem is the "change stage quality" setting. You can overrule that if you set

Code: Select all

vr._quality="HIGH";
Pano2VR 2.1 beta3 should not produce this bug if you disable "Change Stage Quality".
MfG, Thomas

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 12 guests