Page 1 of 1

IFRAME hotspots and charset

Posted: Sun Jan 20, 2019 5:28 am
by MSchneiter
Hi guys,

Thanks to some usefull conversations and tutorials (Tony) below I was able to acheive multi language IFRAME, for displaying standalone HTML files pre-generated as image+text hotspots.
However, I'm having few difficulties displaying the text in the pre-generated HTML files, especially for french (with accents). The problem is that when I open the HTML file manually by double clicking on it, it displays perfectly well. However, when it gets opened through the tour, as an image iframe hotspot, the characters won't display correctly, as if the CHARSET definition from within the tour was changed...

@Martin @Tony, have you already experienced this problem yourself?

Thanks in advance
iframe_direct.JPG
iframe_direct.JPG (103.04 KiB) Viewed 282 times
iframe_from_Tour.JPG
iframe_from_Tour.JPG (117.36 KiB) Viewed 282 times

Re: IFRAME hotspots and charset

Posted: Sun Jan 20, 2019 8:45 am
by Tony
Hi,

It's a common problem with character encoding.

Did you generate the document out of Word? If so make sure the file is stored as UTF-8

You could also run it through an application like TextWrangler or simple text.

You can also try putting this line in <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> in your .html file you use in the iframe. If it doesn't work try it in the index.html file generated by Pano2VR.



Tony

Re: IFRAME hotspots and charset

Posted: Sun Jan 20, 2019 10:56 am
by MSchneiter
Thanks Tony, I had this exact same line in my IFRAME HTML file, but didn't think of updating the main index.htm, which worked like a charm :-)

Cheers

Re: IFRAME hotspots and charset

Posted: Sun Jan 20, 2019 11:32 am
by Tony
Good to know it worked :D