IFRAME hotspots and charset

Q&A about the latest versions
Post Reply
MSchneiter
Posts: 26
Joined: Thu May 10, 2018 5:06 pm

IFRAME hotspots and charset

Post by MSchneiter » Sun Jan 20, 2019 5:28 am

Hi guys,

Thanks to some usefull conversations and tutorials (Tony) below I was able to acheive multi language IFRAME, for displaying standalone HTML files pre-generated as image+text hotspots.
However, I'm having few difficulties displaying the text in the pre-generated HTML files, especially for french (with accents). The problem is that when I open the HTML file manually by double clicking on it, it displays perfectly well. However, when it gets opened through the tour, as an image iframe hotspot, the characters won't display correctly, as if the CHARSET definition from within the tour was changed...

@Martin @Tony, have you already experienced this problem yourself?

Thanks in advance
iframe_direct.JPG
iframe_direct.JPG (103.04 KiB) Viewed 194 times
iframe_from_Tour.JPG
iframe_from_Tour.JPG (117.36 KiB) Viewed 194 times

User avatar
Tony
Posts: 737
Joined: Mon Feb 15, 2010 6:54 am
Location: Adelaide, South Australia
Contact:

Re: IFRAME hotspots and charset

Post by Tony » Sun Jan 20, 2019 8:45 am

Hi,

It's a common problem with character encoding.

Did you generate the document out of Word? If so make sure the file is stored as UTF-8

You could also run it through an application like TextWrangler or simple text.

You can also try putting this line in <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" /> in your .html file you use in the iframe. If it doesn't work try it in the index.html file generated by Pano2VR.



Tony
Tony Redhead | Panoramic Photographer | mobile: +61438501002 | website: http://tonyredhead.com - http://redsquare.com | roundme: http://round.me/@tonyredhead | instagram: https://www.instagram.com/tonyredhead/

MSchneiter
Posts: 26
Joined: Thu May 10, 2018 5:06 pm

Re: IFRAME hotspots and charset

Post by MSchneiter » Sun Jan 20, 2019 10:56 am

Thanks Tony, I had this exact same line in my IFRAME HTML file, but didn't think of updating the main index.htm, which worked like a charm :-)

Cheers

User avatar
Tony
Posts: 737
Joined: Mon Feb 15, 2010 6:54 am
Location: Adelaide, South Australia
Contact:

Re: IFRAME hotspots and charset

Post by Tony » Sun Jan 20, 2019 11:32 am

Good to know it worked :D
Tony Redhead | Panoramic Photographer | mobile: +61438501002 | website: http://tonyredhead.com - http://redsquare.com | roundme: http://round.me/@tonyredhead | instagram: https://www.instagram.com/tonyredhead/

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 15 guests