[P2VR6] How to send out an e-mail containing placeholder values

Q&A about the latest versions
Post Reply
User avatar
dennisvanduijn
Posts: 111
Joined: Wed Apr 28, 2010 10:56 am
Location: Gouda, Netherlands
Contact:

[P2VR6] How to send out an e-mail containing placeholder values

Post by dennisvanduijn » Thu Dec 20, 2018 9:43 am

Hi all,

I wonder if it might be possible to send out an e-mail which contains placeholder details of the 360 degree photo the user is currently viewing.
I use this action to send out an e-mail as soon as a button is clicked:

Mouse Click > Go to URL > Parameters: mailto:?cc=test@test.nl&subject=User data information is $(ui), User data title is $(ut)&body=Test Body

The result is that in place of $(ui) and $(ut) a space is shown. If I want to send out variable values, I know it an be done by adding $(*[name of the varibale]) to de subject or body. That works.

Any thoughts on solving my issue?

Kind regards,

Dennis van Duijn
Commercial 360° tours ● Interior photography ● Promotional printing

Image

http://www.okijk.nl

User avatar
Hopki
Gnome
Posts: 9130
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: [P2VR6] How to send out an e-mail containing placeholder values

Post by Hopki » Fri Dec 21, 2018 1:03 pm

Hi Dennis,
I think you may have put the text in the wrong text field.
Example: If you add text to the user-data description text field the you get a blank.
You're using $(ui) so make sure you add the text to the user-data information text field.
Or if you are using the user-data description then change the placeholder to $(ud).
Regards,
Hopki

User avatar
dennisvanduijn
Posts: 111
Joined: Wed Apr 28, 2010 10:56 am
Location: Gouda, Netherlands
Contact:

Re: [P2VR6] How to send out an e-mail containing placeholder values

Post by dennisvanduijn » Fri Dec 21, 2018 2:32 pm

Hi Hopki,

I see I made a mistake by mentioning the wrong placeholders. It should be $ui and $ut. I have filled the fields where the data should come from, like:

Image

Point is, none of the User Data info is passed on in my mailto:?body=[whatever] parameter if I replace [whatever] with any placeholder. Any other Text Field shows the Placeholder data just fine in the GUI, but sending them by mail fails somehow. Should I use another syntax?

Regards,

Dennis
Commercial 360° tours ● Interior photography ● Promotional printing

Image

http://www.okijk.nl

User avatar
Hopki
Gnome
Posts: 9130
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: [P2VR6] How to send out an e-mail containing placeholder values

Post by Hopki » Fri Dec 21, 2018 6:53 pm

Hi Dennis,
Thats odd because it did for me.
Please see attached project with all user data place holders being used as well as on tin the body text.
Regards,
Hopki
Attachments
e-mail.zip
(12.28 KiB) Downloaded 11 times

Sanny
Posts: 19
Joined: Fri Oct 26, 2018 2:56 pm

Re: [P2VR6] How to send out an e-mail containing placeholder values

Post by Sanny » Fri Jan 04, 2019 11:33 am

Hey,

thank you for the idea!
It worked for me - I sorted it a little bit and made a component to reuse out of it. Maybe it will help someone else. :)

Regards,
Sanny
Attachments
email-button.ggskc
(1.68 KiB) Downloaded 8 times

Post Reply

Who is online

Users browsing this forum: No registered users and 8 guests