Pinned Videos in Nodes problem with IOS playback

Q&A about the latest versions
Post Reply
JPeacock
Posts: 9
Joined: Fri Dec 22, 2017 12:59 pm

Tue Jan 30, 2018 10:42 am

Hi all,
I've created a tour with a Node that features a pinned directional rectangular video on one wall of the panorama.
When users navigate to the node the following happens:

Desktop: The video starts playing on the wall exactly where I've placed it, automatically. It is a thing of beauty. :D

Android: The video is paused on the wall exactly where I've placed it, it plays upon clicking. This is acceptable, I guess in an ideal world it would play automatically but I can live with this.

IOS: The video starts playing in fullscreen mode obscuring the rest of the panorama. This is bad :roll:

Please help!

Tour node is here:

https://onlinevr.co.uk/PUKOutput/index.html
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Jan 30, 2018 5:30 pm

Hi,
Getting a blank page when using your link.
But at one point video did play in the HTML page then after an iOS update it stopped.
I have added a feature request for the developers to look into this again.
Regards to the video being paused on mobiles, you can have the video auto start but with no sound.
We decided it was better to for the video not to auto start without sound as you could miss information.
Time has moved on and we can now have the option.
So a feature request is in to be able to select to auto play, without sound or not.
You can not auto play with sound, the mobile OS prevents this.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply