[SOLVED] Pause sound when video played

Q&A about the latest versions
Post Reply
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sat Jun 03, 2017 7:52 am

Pano2VR 5.2 beta3 Pro. I use HTML5 output only
I use different music or environment sounds (mp3) in each nodes of my multi-node tour. This is not background sound, but this is "pinned" sounds.
Sometimes I use 2 pinned sounds in some nodes.

In some nodes I use video hotspots too (ht_video_youtube and ht_vide_file).
I have troublesome issue of disgusting mixing sound of pinned music and video when video hotspot is open.
To avoid this I use such not elegant "workaround": I place sound on the opposite to video hotspot corner of the node and set sound's horizontal size and ambient to such levels so sound is silent in position of video. But I don't like such solution.

I need advice how to pause all node's pinned sounds when video hotspot is opened and resume that sounds when video hotspot is closed.
Last edited by Vitaly on Sat Jun 03, 2017 9:54 am, edited 1 time in total.
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sat Jun 03, 2017 8:29 am

I just tried to use action in Skin Editor to solve my problem:

I added action for ht_video_youtube hotspot:

Code: Select all

Source: Mouse Click
Action: Media
Type: Stop Media
Target: Element01
But unfortunately this action make no effect, when video opens, pinned sound continues to play.
I tried change type of action to "Pause Media", "Activate Media" (with mode 0) but I can't pause my pinned sound on opening video.
I moved action to top and bottom of action's list. No effect.
Of course my pinned sound's ID is Element01.
It seems like skin's actions make no effects for a pinned sound?
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sat Jun 03, 2017 9:53 am

It's strange, but when I changed pinned sound's ID from "Element01" to "sound1" with corresponding change in action, action works now:

So I added action for ht_video_youtube and ht_video_file elements:

Code: Select all

Source: Mouse Click
Action: Media
Type: Stop Media
Target: sound1

To resume pinned sound after closing video I added action for close button and screentint element (skin "simplex_v5_autohide"):

Code: Select all

Source: Mouse Click
Action: Media
Type: Play Media
Loop: 0 (endless)
Target: sound1
I did not test with 2 pinned sounds in the same node yet.
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Jun 09, 2017 6:44 pm

Hi,
Can you tell me what your platform is, Mac or PC and which version of Pano2VR you are using as this should not happen.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Vitaly
Posts: 34
Joined: Thu Oct 06, 2011 9:12 pm
Location: Ukraine
Contact:

Sat Jun 10, 2017 10:03 am

Hi Martin!
Thank you for your attention. My is Windows 7 x64. Pano2VR 5.2 beta3 Pro x64.
The issue was with default sound's ID "Element01". When I changed ID, problem is solved.
User avatar
Hopki
Gnome
Posts: 10622
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sun Jun 11, 2017 11:24 pm

Ok,
Ill have a look into this this week and in I need to big track to the developers.
If I can't reproduce Ill let you know.
Regards,
Hopki
Hopki
Garden Gnome Software Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply