Pano2vr don't work on Linux

Q&A about the latest versions
Post Reply
wgiocoso
Posts: 4
Joined: Sat Apr 01, 2017 11:41 pm

Pano2vr don't work on Linux

Post by wgiocoso » Sun Apr 02, 2017 10:54 am

Hi,
I've some problems with Linux version of Pano2vr (both 32 and 64 bit version).
I've Linux Mint with KDE based on Ubuntu 14.04 LTS. The execution of your .sh script cause this error:
./bin/pano2vr: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./bin/pano2vr)
The command:

Code: Select all

strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6 | grep GLIBC
show that "GLIBC_2.3.2" is the last version of GLIBC available.

I've searched this error on Internet and I've found that it is more common for users can upload Ubuntu from 14.04 to 16.04 release, but also from users can install MATHLAB. Solution suggested is to add new PPA:
http://ppa.launchpad.net/ubuntu-toolchain-r/test/

New versions of gcc++ are added but pano2vr produce new error:
relocation error: ./bin/pano2vr: symbol _ZNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEE7reserveEm, version GLIBCXX_3.4.21 not defined in file libstdc++.so.6 with link time reference
I've the latest kernel available, 4.4.0-71 but I've also tested your suggested version 3.13.0-37

How can I fix this problem?

Thanks

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Sun Apr 02, 2017 5:47 pm

Hi hate to say it
but 5.02 are the latest version
running on ubuntu 14.04 or Linux Mint 17.03
5.02 and later do not run on the new kernels in 16.4 and 16.10 :!:

i long for a 5.2_64_bit.deb that installs
Pano2VR in the right location
and place a starter in Unity Luncher / Dach.
Image Image

wgiocoso
Posts: 4
Joined: Sat Apr 01, 2017 11:41 pm

Re: Pano2vr don't work on Linux

Post by wgiocoso » Sun Apr 02, 2017 6:15 pm

O.K., but I'm a Google trusted photographer and 5.0 version is not good for me. :(
I can manage manually the positions of files and their linux permissions if you provide instructions.
Thanks

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Sun Apr 02, 2017 9:55 pm

Here are a small screencast on installing Version 5 on Linux Mint 17.03 Rosa ( build on Ubuntu 14.04 ) https://vimeo.com/156805727
you find the older Linux 5 versions on this link https://ggnome.com/pano2vr#downloads

Klick on Show all Downloads :!:

Regards Svendus
Image Image

User avatar
thomas
Chief Gnome
Posts: 2538
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Re: Pano2vr don't work on Linux

Post by thomas » Mon Apr 03, 2017 12:50 pm

I just tried to install Pano2VR 5.2beta2b on a vanilla Ubuntu 16.04.01 and it just works as expected (you have to disable 3D acceleration in VMWare fusion). No additional packages installed.
Screenshot 2017-04-03 12.43.58.jpg
Screenshot 2017-04-03 12.43.58.jpg (134.88 KiB) Viewed 2742 times
MfG, Thomas

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Mon Apr 03, 2017 7:10 pm

All right
Thomas
We are running Linux Native
On a 6 Core intel PC with 16 G Ram NVIDIA 610 Graphic it do not run :?:
Image Image

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Tue Apr 04, 2017 8:45 am

Starting pano2vr_linux64_5_2_beta2b as superuser in the Terminal (Linux Mint 17.03)

Image

/home/svendus/pano2vr_linux64_5_2_beta2b/bin/pano2vr: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/svendus/pano2vr_linux64_5_2_beta2b/bin/pano2vr)

5.0.2 are running

Image

Regards Svendus

We have build Linux computers the last 15 Years

http://svendus.se/datorbygge/index.html
Image Image

wgiocoso
Posts: 4
Joined: Sat Apr 01, 2017 11:41 pm

Re: Pano2vr don't work on Linux

Post by wgiocoso » Tue Apr 04, 2017 11:00 am

Version 5.0.2 isn't available on download page.

The license key is the same for all 5.x versions? Linux and Windows versions work with the same license key?

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Tue Apr 04, 2017 1:27 pm

Yes it is the same key for Version 5 cross platform
Oups you are right got the link from Hopki a month ago but now it has diapered strange :!:

You got a PM with a download

Regards Svendus
Image Image

wgiocoso
Posts: 4
Joined: Sat Apr 01, 2017 11:41 pm

Re: Pano2vr don't work on Linux

Post by wgiocoso » Tue Apr 04, 2017 9:53 pm

Thank you. It seems to work.
I hope that the existing problems are resolved in the new updates and that they are also released into .deb package.

User avatar
Svendus
Posts: 684
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Re: Pano2vr don't work on Linux

Post by Svendus » Mon Jan 15, 2018 11:21 am

The Error GLIBCXX_3.4.20 not found,
are now solved in the latest builds of ubuntu
so you do not get the error any more
/home/username/pano2vr5/pano2vr.sh'
/home/username/pano2vr5/bin/pano2vr: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/username/pano2vr5/bin/pano2vr)


We are now running Linux mint 18.3 Cinnamon 64 bit build on Ubuntu 16.04.3 LTS,

Image
Image Image

Post Reply

Who is online

Users browsing this forum: No registered users and 9 guests