pano.xml file name

Q&A about the latest versions
Post Reply
Carllewis1980
Posts: 30
Joined: Mon May 23, 2016 5:30 pm

Sat Jun 04, 2016 1:22 pm

Is there anyway to change the name of the pano.xml file, to the name of the image as a default?

I have tried changing it in FILE > SETTINGS... > FILES > to $n but as soon as I generate output it changes it to output again
User avatar
Hopki
Gnome
Posts: 11366
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sat Jun 04, 2016 2:08 pm

Hi,
Open a new project file, in settings and file you will see the default name, pano.
Change to $n and click ok. Now restart Pano2VR.
Go to settings and check the setting is saved.
The trick is in the restart.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Carllewis1980
Posts: 30
Joined: Mon May 23, 2016 5:30 pm

Sun Jun 05, 2016 1:01 am

Hi Hopki,

Thanks for the reply, but it doesn't work. If i go back to settings it still states $n but doesn't actually rename the file that?
User avatar
Hopki
Gnome
Posts: 11366
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Sun Jun 05, 2016 10:04 pm

Ok, the fact you say, Settings => Files means your on a PC right.
Ill test at work tomorrow and get back to you.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
mbb
Posts: 244
Joined: Mon Oct 19, 2009 11:42 pm

Fri Oct 19, 2018 6:36 pm

P2VR v.6b4, Win10 64

FYI this appears to still be broken

Changing Settings->Files->Default Filename has no effect.

In my case, this had default of $n, which I needed to change to "pano". Restarting after making the change had no effect, nor did deleting the output folder completely to generate a new one.
mbb
Posts: 244
Joined: Mon Oct 19, 2009 11:42 pm

Mon Oct 22, 2018 8:18 pm

*UPDATE-

My fix for this was to edit the <filename></filename> section of the .p2vr project file in a text editor.
User avatar
Hopki
Gnome
Posts: 11366
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Nov 27, 2018 10:02 pm

Hi Bradford,
I have been looking at this for a while now.
So your request is to have the XML file name to be the same as the first input image.
So in the Setting/Preferences I change the filename to $(n).

If you now add an output you will see the XML field path is now:
output\$(n).xml (PC)
output/$(n).xml (Mac)

On export the output folder has the XML file with the name of the first init image.

In my project I had pano01.jpg, so I ended up with pano01.xml in the output folder.

Going back into the Settings/Preferences if you add $(n) to the folder name.
The next time you add an HTML5 output the name will be the name of your first image and not output.

Again in my example I now have a folder called pano01 with the XML file pano01.xml


I have tested this on both windows and mac so all working.

If you still have issues can you list the steps so I can try and reproduce.
Regards,
Hopki
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply