Page 1 of 3

EXIF information lost after patching and export

Posted: Tue May 31, 2016 7:44 am
by kbaerwald
I would appreciate if Pano2VR5 would write any existing EXIF information into the patched JPGs and TIFs after export. My workflow for Theta S includes levelling with PTGUI and export to 16bit TIF (EXIF included), transfer to Pano2VR5 for patching the nadir and export (EXIF gone).

Any idea?

Klaus

Re: EXIF information lost after patching and export

Posted: Tue May 31, 2016 4:47 pm
by 360Texas
If you are like us we create our patch tripod cap's in Photoshop. Usually a graphic or a cutout from another photo.

For photos at that point our patch has definitely lost its EXIF header data well before inserting the patch into our panorama nadir (bottom).

Pano2vr 5x has its own Theta-S leveling feature. so we do our leveling in Pano2vr.

http://ggnome.com/doc/pano2vr/5/viewer/#leveling

Re: EXIF information lost after patching and export

Posted: Tue May 31, 2016 5:17 pm
by kbaerwald
Dave

basically you are right: I do not care for EXIF when putting together my panos by multiple single shots plus nadir. But from time to time I use the Theta S and it carries the the EXIF (including GPS). The Theta S is not at all perfect but very easy to use for pano reportage.

Even if you do not patch the pano and just import it and then export it: the EXIF is gone. For me it looks like the Pano2VR program drops this information. Would be nice if it could maintain that piece of info.

P.S.: For levelling: I prefer inserting 2 or 3 vertical lines in the PTGUI editor and have my pano levelled perfectly :) .

Re: EXIF information lost after patching and export

Posted: Tue May 31, 2016 5:44 pm
by 360Texas
When I initially input our Theta-S .jpg images (like 4 .jpg node tour group) the thumbnails appear in our Tour Browser marked with the small satellite icons.. meaning Pano2vr Pro 5.x has made a copy of the origials. It uses copies of the Theta-S image group for creating output HTML5 and Flash etc.

I did look around in the Pano2vr Pro' menu for an export feature.. could not locate "Export". Unless you are referring to when you create a pano tour in the OUTPUT area. We usually Output to HTML5 / Multires and create cube groups. I looked at Flash (do not usually use Flash) no export option as the images are now contained in the single output .swf. I do not think once Pano2vr has the copies of your original Theta-S .jpg stored... your originals still maintain the LAT/Long geo -tags in their EXIF header area.

Good discussion. Thank you.

Re: EXIF information lost after patching and export

Posted: Tue May 31, 2016 6:43 pm
by kbaerwald
Right you are - the GPS information is not lost when "exporting" to a <pano.tif> but all other EXIF info. Btw: with export I refer to the output function of Pano2VR.

When shooting with the Theta S in reportage mode I usually don't have a tripod. I just take a selfie stick with a grip (approx 1m) put the Theta S on it and hold it high in the air. This leaves me in the nadir as a nearly bald-headed person as you can see from the given example! Unfortunately I have no real vertical control of the camera so that levelling is always required after a pano shooting session. With Pano2VR it is too much trial & error so I prefer PTGUI. The next step is to remove any chromatic aberration and improve the pano with LR. In the end I have to remove "Klaus-as-a-nadir". This works best with Pano2VR and PS. Currently my goal is to have an equirectangular pano which can be shown on a tablet. In future I will use the pano tour features more often but currently I "abuse" Pano2VR mostly for patching (I hope no developer reads this conversation :oops: ).

You can find an example here (Catedral de Sto Domingo de la Calzada, Northern Spain):

https://onedrive.live.com/redir?resid=E ... lder%2ctif

Klaus

Re: EXIF information lost after patching and export

Posted: Tue May 31, 2016 7:59 pm
by 360Texas
Yes, I do see where a couple of PTgui vertical control point does a great job.. compared to the left photo which has completely missed any vertical alignment.

I see you are also using Microsofts cloud oneDrive. Good for show and tell.

Thanks

Dave still at 360texas.com

Re: EXIF information lost after patching and export

Posted: Wed Jun 01, 2016 3:13 pm
by Hopki
Hi,
This has been added to the bug tracker.
As we write the XMP for GPS we remove the Exif, but this is needed for the Theta.
This worked in version 4.x, but you had to go to Pano2VR Settings/Preferences and under the Exif tab deselect all the check boxes.
Pano2VR 4 can run along side version 5 as they have different install directories.

For those people that don't have version 4, you can copy the Exif from the original image and paste it in the new parched image using in LightRoom.
Not don this myself but others are reporting this works ok.
Regards,
Hopki

Re: EXIF information lost after patching and export

Posted: Wed Jun 01, 2016 8:26 pm
by kbaerwald
Hi Hopki

can't find a way to copy exif from one file to another within LR6. Anyway - if it is on the bug tracking list that's o.k. for me. There are other tools for copying that EXIF information (Breezebrowser, Exiftool) but that is an extra step.

Regards, Klaus

Re: EXIF information lost after patching and export

Posted: Wed Jun 01, 2016 10:01 pm
by Hopki
Hi Klaus,
You could use your version 4 build to patch?
Regards,
Hopki

Re: EXIF information lost after patching and export

Posted: Thu Jun 02, 2016 8:35 am
by kbaerwald
Hello Hopki

yes - already started with it by reinstalling V4 for future use. Currently I have to retag some hundreds of Theta files from my visit to Spain and use BreezeBrowser for it.

Regards, Klaus

Re: EXIF information lost after patching and export

Posted: Sun Jan 29, 2017 4:23 pm
by visual360media
I agree with the above. Has this been sorted yet? Bug report was last year. Ive just been playing with theta, i drag pano into pano2vr 5, export patch to PS, back into pano2vr and then save the equi. I upload to google maps and it has lost gps even though in my pref settings i have save gps checked. I hope as you have the beta out this very important issue has been addressed. All exif should be saved and once file edited, dumped back to final equi on save. Can someone please let us know if this has been fixed, if not, why not? Thank you. John G

Re: EXIF information lost after patching and export

Posted: Sun Jan 29, 2017 9:14 pm
by Svendus
Hi guys
We noticed this when we from old habbit with an old fisheye lens converted to Cube faces, do to fix the the hole in the sky
and removing the tripod, here the GPS info was lost, when building the pano from Cubic Projection
So we canged the workflow and now work with Equirectangular Projection and Patching with the Pano2VR5.1 Patch tool
Everything is working nicly

Regards Svendus

Re: EXIF information lost after patching and export

Posted: Mon Jan 30, 2017 10:48 am
by kbaerwald
Just to remind: it is not only the GPS information that should be maintained but the whole EXIF stuff! I understand that in working the traditional way (stitching several photos to one panorama) that information is of little interest because it is lost anyway. But working with a camera that delivers the panos out-of-the-box including all the exif information - this should be maintained.

Again - I want to second John G. for asking the question if this problem has been fixed.

Thanks, Klaus

Re: EXIF information lost after patching and export

Posted: Mon Jan 30, 2017 2:14 pm
by Svendus
Hi Klaus
sorry to interfere here are two Theta exif data
Theta-exif.zip
(3.79 KiB) Downloaded 60 times
it is interesting to see what you are missing and how you use it ?

theta JPG
theta-converted JPG

Regards Svendus

Re: EXIF information lost after patching and export

Posted: Mon Jan 30, 2017 4:41 pm
by kbaerwald
Hi Svendus

just restarted and re-checked my workflow:

- Import ThetaS JPG into LR -> some tuning -> converted to TIF (EXIF info is available)
- new TIF taken into PTGUI -> realigned the pano -> saved the pano into a new TIF (EXIF still existing)
- new TIF taken into Pano2VR (5.03 15088/5.5.1) -> patched it with PS 5.5 -> saved the pano into a new TIF (transform equirec)
- new TIF checked in LR (GPS data available, other EXIF data gone)

Basically the same situation as 8 months ago.

So could you please tell me which EXIF information you have taken from what ThetaS pano during your workflow? I would be very interested how you preserved your EXIF data.

Regards, Klaus