Error opening on Ubuntu 16.04

Q&A about the latest versions
Post Reply
SLFennessy
Posts: 12
Joined: Tue Apr 05, 2016 4:50 pm

Thu Apr 21, 2016 10:00 pm

I just upgraded my system to Ubuntu 16.04 (I did a clean install) and I'm receiving the following error when trying to open Pano2VR:

Code: Select all

./bin/pano2vr: error while loading shared libraries: libgstapp-0.10.so.0: cannot open shared object file: No such file or directory
Is this effecting anyone else? Does anyone have any idea how to fix it?
Thanks!
SLFennessy
Posts: 12
Joined: Tue Apr 05, 2016 4:50 pm

Thu Apr 21, 2016 10:04 pm

I found a solution (quickly). In order to get Pano2VR to open I needed to install libgstreamer0.10-dev
Just cut and paste this into the terminal and install, it works.

Code: Select all

sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
User avatar
360Texas
Moderator
Posts: 3516
Joined: Sat Sep 09, 2006 6:06 pm
Location: Fort Worth, Texas USA
Contact:

Thu Apr 21, 2016 10:07 pm

Svendus probably knows more than I do. He is in Sweden -- time zone closer than I am.

I left a Skype note for him to please read your comment tomorrow.
Dave
Pano2VR Forum Global Moderator
Image
Visit 360texas.com
User avatar
Svendus
Posts: 686
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Fri Apr 22, 2016 4:22 pm

Code: Select all

sudo apt-get install libgstreamer0.10-dev libgstreamer-plugins-base0.10-dev
installing libgstreamer0.10 did not work for me on a virtual installation of Xenial Xerus (Ubuntu 16.04 LTS)

i am running Linux Mint 17.3 "Rosa" Cinnamon Edition build on Ubuntu 14.04 LTS
and i docent think i ever go back to Ubuntu with Unity
Image Image
User avatar
thomas
Chief Gnome
Posts: 2565
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Thu Oct 20, 2016 8:17 pm

I plan to build Pano2VR 5.1beta on the new Ubuntu 16.04 LTS, but I still have no luck with deploying it onto a clean installation (=without developer tools). I hope I can release the first package soon, but the webview still causes major pain.
MfG, Thomas
User avatar
Svendus
Posts: 686
Joined: Sun Jan 06, 2008 11:03 am
Location: Sweden
Contact:

Sat Feb 06, 2021 12:08 pm

We are now on Linux Mint 20 Linux 5.4 kernel
https://svendus.se/blog/?p=3201&lang=sv#.YB7cbi186hA
and the only way to install Pano2VR 6.0.6
are to install Version: 6.1.10 pro 64bit.exe and running it through G4wine on Linux Mint 20

Image

Image

so if Garden Gnome developers do not create a .deb installer for Pano2VR 6.0.6
i think it was time for a complete wine package for
Panorama Tour Builder
Version: 6.1.10 pro 64bit
Revision: 18007/5.12.2
that should make things much easier
Image Image
Post Reply