Video Autoplay

Q&A about the latest versions
Post Reply
SteveL58
Posts: 27
Joined: Fri Dec 04, 2015 6:18 pm

Video Autoplay

Post by SteveL58 » Sat Dec 05, 2015 6:28 pm

Newbie to Pano2VR. I have Pano2VR5 and trying to figure out how I can get an embedded video to not autoplay. What I am trying to do for instance is I have a video embedded on a TV screen...when a person enters the pano it does not automatically play. Instead...I have a button that will allow them to Play/Stop the video.

The second part of the question is I created a text that says Play....which plays the video in the TV....and now I only want that button visible whenever anyone goes to that particular pano in the tour.

Any ideas on how I can do this?

SteveL58
Posts: 27
Joined: Fri Dec 04, 2015 6:18 pm

Re: Video Autoplay

Post by SteveL58 » Sat Dec 05, 2015 8:25 pm

Ok...I figured out all I needed to do was put -1 in the loop to prevent the video from playing automatically.

Still trying to figure out how the text button I put in the skin editor can be removed when you click on a hotspot that doesn't have that video in it.

User avatar
Hopki
Gnome
Posts: 9651
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Video Autoplay

Post by Hopki » Sat Dec 05, 2015 9:57 pm

Hi Steve,
Under user data add the tag, say "vid".
Then in the skin you can use the text box visibility logic block to detect the tag, when detected show.
Regards,
Hopki

SteveL58
Posts: 27
Joined: Fri Dec 04, 2015 6:18 pm

Re: Video Autoplay

Post by SteveL58 » Sat Dec 05, 2015 11:48 pm

Awesome...thank you very much...works great!

User avatar
HFlouch
Posts: 28
Joined: Tue Jun 06, 2017 2:25 pm

Re: Video Autoplay

Post by HFlouch » Tue May 15, 2018 1:12 pm

I'm trying to do the same thing - to disable the auto-play feature for a pinned and aligned video. If I enter 1 a the Loop filed, it disable replay but it doesn't stop the initial autoplay. Is there another way to do this? Does your last suggestion achieve this Hopki? If so, I'd really appreciate a couple of pointers as to how to do what you say.

User avatar
Hopki
Gnome
Posts: 9651
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Re: Video Autoplay

Post by Hopki » Tue May 15, 2018 11:17 pm

@ HFlouch
Set Loop to -1 to stop auto play.
This is in the documents on our website.
Look under pinned video and Loop.
Regards,
Hopki

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 6 guests