[Solved] Crackling Sound on iPad Package Viewer

Q&A about the latest versions
Post Reply
jimmyhii
Posts: 3
Joined: Fri Jun 11, 2021 11:56 am

Wed Sep 15, 2021 8:35 pm

Hi,

I'm having trouble with a crackling sound when viewing my tour specifically on an iPad using the package viewer app. My tour has a different ambient sound on each node, and I've simply set it to loop and to be a static sound. However when viewing the tour, after moving around the tour a bit a crackling sound can be heard both through the iPad speakers, and even with earphones/headphones.

Some observations:
- I don't think the sounds are related to the audio files. I'm using .mp3s with 44.1kHz sampling and 192kbps so nothing out of the ordinary. The files are not huge either, they're quite short so about 1MiB each or less. Furthermore, the crackling sound does not happen at the same place in the audio.
- The crackling sound will start manifesting after viewing the tour for a while. When you've moved through a few nodes, the sound begins, and then it gets progressively worse over time. Even when you move to a node that has a sound that was not 'crackly' before, the crackling will be there too.
- I tried staying on the initial node for a long time, without moving and the crackling still happens.
- Once the crackling starts, it happens constantly, regardless of node you're on or the sound that's being played.
- The crackling starts intermittently and softly at first, but progressively gets louder and more frequent over time. This does not change between sounds/nodes as well.
- When the crackling gets bad, the sounds also often stop for many seconds before playing again.
- When playing the tour on my PC (Windows machine, using Chrome to view), this has never happened.

I have a few guesses but I'm not a very technical person so it's really just guesses:
- Could this be a memory problem, perhaps the tour is not unloading sounds as the viewer moves through the various nodes?
- Is there some issue with how the package viewer handles sound on iOS?

Is anyone else having this issue, and are there any work-arounds? I delivered the tour to my client as a package to view with the viewer since the tour is big and they only want to use it offline. Is there any alternative way to do this that might eliminate any potential issue with the package viewer app? Thank you!

For reference, I've attached a recording of the crackling sounds. The sound being played in the tour are rainforest sounds, so what you're hearing are the insects.
crackling_recording.MP3
(1.16 MiB) Downloaded 68 times
Last edited by jimmyhii on Sat Sep 18, 2021 5:39 am, edited 1 time in total.
User avatar
Hopki
Gnome
Posts: 11725
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Sep 15, 2021 9:04 pm

Hi
Are you able to send the project with the output folder?
The problem is I can not reproduce the issue. Had a package sent to me that had the issue. Then the project was sent. When making the package on my computer the issue has gone.
So what I am after is another project that has this issue.
If you could send it to support using something like Wetransfer that would be good.
Have you tried using .AC3 file then MP3 as fullback.
The problem is Apples inability to support web audio properly, but I remember using a different file type worked.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
jimmyhii
Posts: 3
Joined: Fri Jun 11, 2021 11:56 am

Thu Sep 16, 2021 5:52 pm

Hi Hopki,

Sure! I reduced the size of the panos so it's not too huge to send to you, but I've tested this reduced pano size version on my iPad and it's still got the crackling sound. I'm uploading it now, I'll send it to the support email shortly. Thank you!

I'll also try out using .AC3 tomorrow and report back. I tried using OGG as a backup file as suggested in another forum post, but it didn't seem to help.
jimmyhii
Posts: 3
Joined: Fri Jun 11, 2021 11:56 am

Sat Sep 18, 2021 5:38 am

Thanks for your help Hopki!

This was the solution that Hopki suggested, and works for me. I hope anyone else who has this issue will find this useful! To summarise:

My Original Tour:
- Had a Sound on each node set to static and infinite loop with an ambient sound for each node.
- On iPads, there is a crackling noise that happens after about 4 mins in the tour. This is not related the the files, but an issue with how Apple deals with websounds.

What I did:
1. Remove the sound items in each node.
1. Add all the sound audio files as assets in the project. This is done in the Output Tab, under 'Advanced'.
2. Create a new video element in your project skin. It doesn't matter where it's placed. To be safe, I set the video element to have 0 alpha so it wouldn't be visible.
4. Under properties of the video element, I made sure "Autoplay" and "loop" were selected.
5. Under actions of the video element, Add a Set Value action whenever there is a Node Change. For my project I used the comments from user data for each node to store the path, the placeholder for that is $(uo). This is what the action looks like:
node_change.png
node_change.png (10.44 KiB) Viewed 251 times
6. Add the asset path for the sound you want played on the node to the node's comment under User Data. For example, if I wanted "1Entrance.mp3" to be played, I would type "assets/1Entrance.mp3" in the comments field. This is what it looks like for me:
node_info.png
node_info.png (25.59 KiB) Viewed 251 times
In my case, I also used the other fields to store information for other features in my tour, so you can ignore them.

The sounds should playback the same now, but you won't face the crackling issue anymore because the iPad treats it as a standard audio instead of a web audio this way. I hope this helps! If anyone has suggestions on how to do this more elegantly please feel free to let me know!
User avatar
Hopki
Gnome
Posts: 11725
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Sep 20, 2021 9:31 am

The good news Apple know they have An issue so hopefully there will be a solution on the way.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
User avatar
k.ary.n
Gnome
Posts: 522
Joined: Wed Aug 15, 2007 1:02 pm

Mon Sep 27, 2021 11:28 am

This has been fixed in iPadOS 15. At least my crackling projects are no longer crackling.
Post Reply