VR not working, only gyro function

Q&A about the latest versions
Post Reply
David R
Posts: 6
Joined: Thu Dec 24, 2020 10:31 pm
Location: Hobart, Australia
Contact:

Wed Jun 16, 2021 10:28 am

I created a tour with a VR button with the action 'Enter VR'.
When this is tapped, only the gyro function happens, there is no dual VR windows when turning the phone sideways.
How do I get this working?
When it is working, how do I transition between scenes?

Thanks for any help.

Link to tour: https://tourview.com.au/p2vrtest/aurora-australis.html
Regards,
David R
User avatar
Hopki
Gnome
Posts: 11533
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Jun 16, 2021 3:34 pm

Hi David,
There seems to be something covering the WebVR button.
Hence why when you select it, you see the gyro button react and you select gyro.
Check for any containers or invisible elements that could be getting in the way.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
David R
Posts: 6
Joined: Thu Dec 24, 2020 10:31 pm
Location: Hobart, Australia
Contact:

Thu Jun 17, 2021 12:23 am

Hi Martin,

Thanks for taking a look.

I have moved the VR button away from the background rectangle, and it did not make any difference.
I also checked that the container (holding all of the control buttons at the bottom) was ticked as 'Permeable'.

All of the other buttons work and are in the same container, but the VR button only makes the tour go to Gyro?
It seems to activate the gyro button when pressed.

Sorry, I can't seem to fix the issue, maybe I'm missing something fundamental, and this is my first tour using Pano2VR.

Are you able to look at the skin?
Regards,
David R
User avatar
k.ary.n
Gnome
Posts: 518
Joined: Wed Aug 15, 2007 1:02 pm

Thu Jun 17, 2021 2:50 pm

When I try your project, tapping the VR button only turns on the Gyro.

How did you add the button? Technically, all you need to do is add the Enter VR button from the components toolbox (and then change the icon). Then make sure "VR" is selected in the HTML5 Output settings (it's selected by default). As is outlined here: https://ggnome.com/doc/hmd-how/.

Is that how you added the button?

What actions do you have connected to the VR button?
User avatar
Hopki
Gnome
Posts: 11533
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Thu Jun 17, 2021 4:16 pm

The easiest thing to do is just post your skin.
Regards,
Hopki
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
David R
Posts: 6
Joined: Thu Dec 24, 2020 10:31 pm
Location: Hobart, Australia
Contact:

Fri Jun 18, 2021 12:12 am

Hi Hopki and k.ary.n,

I added the Silhouette VR button from the components toolbox and changed the icon.
I added the action 'Enter VR' on mouse click.
I made sure VR was enabled in the output settings (it was ticked by default).

After I reported this post, I tried adding the Silhouette VR button again and positioned it at the very top of the skin tree (separate from the other control buttons and not under any other elements).
It still does the same thing – just starts the gyro function?

I've sent the skin via support@ggnome.com

Thanks for your help.
Regards,
David R
Post Reply