Pano swf loading issue

Specific Q&A about the new Flash export
Locked
vkidd
Posts: 2
Joined: Fri Aug 24, 2007 4:29 am
Contact:

Fri Aug 24, 2007 4:56 am

First let me say great product! I love the functionality and ease of use.

Now to the problem.
My flash website and actionscript are all set up. My pano.swf loads in to my website perfectly when i debug test my website from flash8, or when i run my website of my local drive in Firefox.

However, when i upload everything to my host server (i'm using directnic for hosing) and access my website on the internet the pano doesn't load.
I don't think its a problem with my hosting because i'm loading video (.flv) files that are about the same size, and they work just fine.

Heres my code: ////////////////////////////////////////////

var vr:MovieClip = _root.createEmptyMovieClip("vr", 1);
vr._lockroot = true;

var myLoader = new MovieClipLoader();
var myListener = new Object();

myListener.onLoadStart = function () {
// move the upper left corner
vr.window_x=58;
vr.window_y=117;

//resize pano
vr.window_width=282;
vr.window_height=253;
vr._xscale = 160;

//initial viewing parameters
vr.pan=0;
vr.tilt=-5;
vr.fov =70;

//set autorotation
vr.autorotate = 0.8;
vr.autorotate_delay = 3;
};

myLoader.addListener(myListener);
myLoader.loadClip("demoreel/Interiorpano.swf",vr);

////////////////////////////////////////////////////////////

any help is greatly appreciated.
User avatar
hum@no.id
Posts: 945
Joined: Sat Sep 09, 2006 10:35 pm
Location: Dark side of the Moon
Contact:

Sun Aug 26, 2007 12:40 pm

Much rightslash beautifully...

but... better if so

Code: Select all

var vr:MovieClip = _root.createEmptyMovieClip("vr", 1); 
vr._lockroot = true; 

var myLoader = new MovieClipLoader(); 
var myListener = new Object(); 

myListener.onLoadStart = function () { 
// move the upper left corner 
vr.window_x=58; 
vr.window_y=117; 

//resize pano 
vr.window_width=282; 
vr.window_height=253; 
vr._xscale = 160; 

//initial viewing parameters 
vr.pan=0; 
vr.tilt=-5; 
vr.fov =70; 

//set autorotation 
vr.autorotate = 0.8; 
vr.autorotate_delay = 3; 
}; 

myLoader.addListener(myListener); 
myLoader.loadClip("demoreel/Interiorpano.swf",vr); 
vkidd
Posts: 2
Joined: Fri Aug 24, 2007 4:29 am
Contact:

Sun Aug 26, 2007 5:28 pm

i still haven't figured out why this is happening. Does anyone have any ideas?

Again the problem is that my pano.swf loads in to my website perfectly when i debug test my website from flash8, or when i run my website of my local drive in Firefox. But it does not load when i access my website on the internet.
User avatar
thomas
Chief Gnome
Posts: 2564
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Sun Sep 02, 2007 6:43 pm

Can you send us a link?
MfG, Thomas
Locked