problem to show my swf in a fla

Specific Q&A about the new Flash export
Locked
jack73
Posts: 6
Joined: Wed Nov 19, 2008 3:54 pm
Location: France - Savoie

problem to show my swf in a fla

Post by jack73 » Sun Dec 21, 2008 5:29 pm

Hello,

When I place this code on my page, it doesn't work. When I edit my page to see the result, the page is white, nothing appears...

var vr:MovieClip = _root.createEmptyMovieClip("vr", 1);
vr._lockroot=true;
// move the upper left corner
vr._x=100;
vr._y=200;
var myLoader = new MovieClipLoader();
var myListener = new Object();
myListener.onLoadStart = function () {
// Set the dimensions and position of the pano
vr.window_width=500;
vr.window_height=380;
vr.window_x=100;
vr.window_y=10;
};
myListener.onLoadInit = function () {
// your initalisation of the pano, add Hotspots,...
// You can also set the window size here but you need to use the API
vr.pano.setWindowSize(500,380);
};
myLoader.addListener(myListener);
myLoader.loadClip("mypanorama.swf", vr);


Of course I named my swf correctly.
I don't understand where it comes from... I use the MX version.

Many thanks to who can help me,

Jack

User avatar
thomas
Site Admin
Posts: 2462
Joined: Fri Sep 01, 2006 3:56 pm
Location: Vienna, Austria
Contact:

Re: problem to show my swf in a fla

Post by thomas » Mon Jan 05, 2009 1:28 am

You need at least Flash 8 to make this work.
MfG, Thomas

jack73
Posts: 6
Joined: Wed Nov 19, 2008 3:54 pm
Location: France - Savoie

Re: problem to show my swf in a fla

Post by jack73 » Tue Jan 06, 2009 8:51 pm

OK Thomas, thank you. I understand now...

Jack

Locked

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest