"EXTERNAL_MESSAGE": "Photo with id: XXXX does not exist."

Post Reply
BrideValley
Posts: 35
Joined: Fri Sep 29, 2017 2:13 pm
Location: England

Mon Jun 27, 2022 6:48 pm

Has anyone had a message like this when trying to publish a tour to GSV:

{
"error": {
"code": 404,
"message": "Photo with id: CAoSLEFGMVFpcE1TakpfXzJoN2lXTzlCVG5yT1UyRVh5eEJUc2drQUNNWVFYUmlO does not exist.",
"status": "NOT_FOUND",
"details": [
{
"@type": "type.googleapis.com/google.rpc.ErrorInfo",
"metadata": {
"EXTERNAL_MESSAGE": "Photo with id: XXXX does not exist."
}
}
]
}
}


Request:
{
"connections": [
{
"target": {
"id": "XXXX"
}
},
{
"target": {
"id": "XXXX"
}
}
],
"places": [
{
"placeId": "XXXX-I"
}
],
"pose": {
"heading": 313.765,
"latLngPair": {
"latitude": xx.8504305,
"longitude": xx.37901781
}
}
}

4 of the panos in a tour consisting of 6 panos generated this error. I saw it a week or so ago too, and the message is repeated if I try to upload again.

I have no idea what the error message means. Could anyone translate?

Cheers

Simon
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Jun 27, 2022 7:32 pm

Hi Simon,
Firstly the topic has been moved to the correct forum.
More chance of someone here has seen this before rather than in the General forum.

But this is more than likely a problem with the account.
Are you trying to replace a panorama that is already uploaded to Street View?

Are you uploading an image you recently removed?
If so, check your account on Maps, do you see the panorama?

Remove the panorama/tour from Pano2VR using the delete button in the Street View Browser.
Refresh the page, do any of the images return?

Now go to Google Maps and log in with your account and go to your contributions.
Do you see any of the panoramas there? If delete them using Maps.

Then finally open your Street View Phone App.
Do you see any of the images there?
Again, if so delete them from the APP.

I would give it 24hr then check again making sure none of the images is on Street View using Pano2VR, Google Maps and the Street View APP.

Once you are happy they are all gone, upload again.
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
BrideValley
Posts: 35
Joined: Fri Sep 29, 2017 2:13 pm
Location: England

Mon Jun 27, 2022 7:42 pm

Hi Martin

Apologies for posting to the incorrect forum and thanks for sorting that out.

This is the 49th tour I've uploaded to GSV this year and none of the 6 panoramas had been uploaded previously. So, no, I was not uploading a pano to replace one uploaded previously.

I will follow your suggestions however and try again in a day or so.

Thanks for the help. I'll let you know what happens.

Simon
BrideValley
Posts: 35
Joined: Fri Sep 29, 2017 2:13 pm
Location: England

Mon Jun 27, 2022 7:47 pm

Actually, all 6 appear in the Pano2VR Street View Browser but are not attributed to any business. Maybe because I attempted to publish them only an hour or so ago. Just as an experiment I hit the "Upload project to Strett View" button again and Pano2VR said that 6 images were found in my collection and proceeded to uploadthe metadate without error. Perhaps I'll leave things alone now and check back tomorrow to see if they've "taken hold".
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Mon Jun 27, 2022 8:14 pm

Hi Simon,
No worries about the forum but you have more chance of someone answering as Street View is not everyone's go-to output.
If you are using Pano2VR 7, in the Street View Browser you will see Map Status.
This shows if your panoramas are Maps Accepted or Maps Rejected, gree tick or red cross.
In Pano2VR 6 pro it does not show this so you need to use the Street View app, select one of your panoramas and it should say if it's Maps Approved or not.
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
etegration
Posts: 84
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Tue Oct 11, 2022 9:00 am

Code: Select all

{
  "error": {
    "code": 404,
    "message": "Photo with id: xxxdoes not exist.",
    "status": "NOT_FOUND",
    "details": [
      {
        "@type": "type.googleapis.com/google.rpc.ErrorInfo",
        "metadata": {
          "EXTERNAL_MESSAGE": "Photo with id: xxxdoes not exist."
        }
      }
    ]
  }
}


Request:
{
    "connections": [
    ],
    "places": [
        {
            "placeId": "xxx"
        }
    ],
    "pose": {
        "altitude": 66.898,
        "heading": 8.535000000000025,
        "latLngPair": {
            "latitude": 1.311527,
            "longitude": 103.735497
        }
    }
}
im having the same issue. could it be due to name of the location? it is a new panorama and i have not uploaded it before.
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Oct 11, 2022 4:54 pm

Hi,
Down the rabbit hole we go :lol:

What this may be is Google deleting or replacing the Photo ID.
If you open the Pano2VR project file, in the Street View Browser do you see the Place ID and the Green connection icons for each node?

Screenshot 2022-10-11 at 15.05.43.png
Screenshot 2022-10-11 at 15.05.43.png (250.4 KiB) Viewed 1441 times

What you may see is the amber connection icon showing one or. a few nodes are not connected to the project.

1.png
1.png (166.92 KiB) Viewed 1441 times

What you can do is select the panorama in the Tour browser, then open the Stree View browser, right button click on one of the disconnect nodes and connect it.

2.png
2.png (391.44 KiB) Viewed 1441 times


This may solve the issue.
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
etegration
Posts: 84
Joined: Fri Mar 30, 2007 7:28 pm
Contact:

Wed Oct 12, 2022 2:53 am

thank you. seems to solve it. Does this mean it is trying to be part of a tour when it is actually not? as it is a single node when i am uploading it to googe maps but its trying to be a sub node.
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Wed Oct 12, 2022 9:49 am

Hi,
At the moment all we know is Google is deleting or changing the Photo ID on their end.
This causes a disconnect so Pano2VR thinks 404, file not found.

Can we ask, when you had the 404 did you see the yellow warning icon in the Street vIew browser?
You then reconnected to it and it turned green?

We want to have as much information as possible so we can add it to the Troubleshooting & Reporting issues to Street View post.
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Javier B
Posts: 88
Joined: Wed Sep 23, 2020 11:59 am

Tue Dec 13, 2022 12:11 pm

Hi all.

I have to say that both problems happen to me too recently.

Cheers
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Tue Dec 13, 2022 9:35 pm

Hi Javier,
Do you use your own Google Street View API key?
If so try removing it from Pano2VRs Settings/Preferences which means you will use ours.
Does that make any difference?
Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Javier B
Posts: 88
Joined: Wed Sep 23, 2020 11:59 am

Fri Dec 16, 2022 12:26 pm

Hello Hopki.

I publish with the Pano2Vr API I guess because I have never had API.I don't remember this happening with version 6, or at least not that often, and I always gave a solution. Now it has been impossible for me.
After dozens of attempts with Pano2Vr ver7 spaced between hours and days since last week, today I decided to publish it from Panosking and it was instantaneous. The tour is published and all linked in a matter of minutes.
There is something wrong with Pano2Vr 7 in its publishing tool for Google: it freezes when you search for a published tour, it publishes panoramas outside the listings, it gives deletion errors and it doesn't allow you to publish certain panoramas. This last case published tour applies to everything I have just described.
As always, thank you very much for your attention, Hopki.

Javier
User avatar
Hopki
Gnome
Posts: 12517
Joined: Thu Jan 10, 2008 3:16 pm
Location: Layer de la Haye, Essex UK
Contact:

Fri Dec 16, 2022 6:34 pm

Hi Javier,
This is more than likely an account issue.
Panoskin and others that are cloud-based use their own account, so you upload through them.

As a test, I have a three-node project that I use to delete and upload to test with.
Pano2VR 7 does have an issue when you delete a tour with the blank window, but the search is not having an issue we can see.

The tour I remove I just uploaded again and within a few minutes it's up with the place ID, not seeing any links just yet but as said I have only just uploaded it.
If I see links within an hour then I think this will be acceptable.

The thing you have to remember is that Pano2VR does not change, the variables are your own Google account and your Street View API Key.
You can eliminate the API key by using ours.
For the account, it may be worth creating another Google account and having that as a test account.

Regards,
Garden Gnome Support
If you send an e-mail to support please send a link to the forum post for reference.
support@ggnome.com
https://ggnome.com/wiki/documentation/
Post Reply